Arm/Flipper Bone moves lower area of mesh

Hi I’m having an issue with the skeleton in Blender

Every time i set it up on the model i made (penguin) if i try to move either of the bones in the flippers it moves the a good portion of the lower half of the body instead I’ve made sure all the bones were in the body when i was making it and that none of the bones win the arms were to large or to close to the bottom but it still move that part and ignores the arm.

Here is the .blend file If any of you guys can figure out what i did wrong it would be much appreciated =)


Penguini.blend1.blend (244 KB)

Well i managed to fix it moving the lower half of the mesh, I turned off vertex groups and left on envelope but now now matter how big i make the dist. the arm it only moves a small portion of the arm.

Nvm fixed it just had to move some bones around and change their sizes a bit