Armature not working, PLEASE HELP!

Okay. I recently got Blender and after derping around a while managed to make a pretty decent model. I decided I want to give animation a shot and after various tutorials managed to set up an armature. HOWEVER.
Every tutorial I could find was for older versions of Blender (I have 2.69). I tried manually weight painting the model, but now whenever I move a bone, the entire body moves with it. I say the entire, but I’ve actually got a second problem with the program: I made the Model in a couple different stages. I have the body, legs and arms, there’s the left hand, the right hand, the head, the eyes, the first bit of hair, the hairband, the second bit of hair and the mask, all in seperate models and imported to one figure.
is there any way at all to join them into one model, and is that the cause of my problem?
I’m desperate for help. again, I’m using 2.69.
Thank you for taking your time to read this. I joined the forum for this post, so I hope you can help me.
I attached a couple of screenshots of the model. it’s Midna from The Legend Of Zelda: Twilight Princess.
-The desperate Moblinkebab


This is what it looks like when I move any Armatures.


Select all mesh objects in object mode, then press ctrl+j to join.
Its not the cause of the problem, you can weight separate mesh objects to one armature.

From the last picture, it looks like parts of the mesh objects are not weighted to any bones.
There are different ways to weight meshes to armature bones, Auto Weight, Assign weight to selected vertices using the vertex groups panel in edit mode, parent mesh object to pose bone, etcetera.

Im not sure what would be the best way for this model, probably join objects then parent with automatic weights for most the model, then add corrections.

T H A N K Y O U.
At least the first bit worked, it turned enormous, but I downscaled it and it’s now one model.
But, and please forgive my noobishness, how DO you join and auto pair objects here, and how DO you add corrections?
I tried selecting the model and armature then pressing ctrl+P, but it doesn’t show anything except ‘‘Object’’, ‘‘Object (keep transform)’’, ‘‘Vertex’’ and ‘‘Vertex (Triangle)’’. I tried selecting the object first and more options showed up, but every one showed an error message stating ‘‘Loop in parents’’. I’m begging you, could you please explain this if possible.

Thank you for your help. I appreciate it greatly, mr. dirty-stick.
My model is now finally one. But I’m still having problems. How exactly do I auto parent? if I select the object first, then the armature, then press ctrl+P, it brings up the options to set my parent to. Object does nothing, Envelope does nothing, and all the others say ‘‘ERROR: loop in parents’’. What is the problem now, and could you maybe help me?

You probably set the mesh as the armature parent.
First try select the armature in object mode, alt+p, clear parent.
Then with the mesh and armature in object mode, select the mesh then the armature, then ctrl+p, parent with auto weights.

There may be other problems with the rig, but I dont want to guess them.

No, it’s not working…
Whenever I select it, it just says Loop in parents… could I maybe send you the model?

Thats up to you.
Files can be uploaded to or use a different webpage if you like.

Maybe someone else knows what the problem may be.
Im guessing its something todo with the way the objects are parented.
Checking the outliner may help.

I’ll see. I’m gonna upload it to this anyway, but I appreciate your help!