Arnold for Blender: 0.2.0 Alpha Available

For anyone having any installation issues, I just pushed a new patch to the latest alpha branch that no longer requires you to set the ARNOLD_ROOT or LD_LIBRARY_PATH environment variables by hand. You can still set ARNOLD_ROOT if you’d like, but if not you can now properly set it in the add-on preferences and BtoA will handle the rest.

1 Like

was empty/green render solved??

It’s on the list of things to do but it’s not happening this week. It’s scheduled for Alpha 0.4.0, which is probably a couple of weeks out at the moment.

Edit: To clarify, the green render (viewport rendering) is what I’m referring to. When you get a transparent render, it’s usually a sign of an error happening during the render itself, and can happen for a handful of reasons. Be sure to look in the console window to see what Arnold doesn’t like. Currently, it’s most commonly because you’re trying to render with an Arnold version either pre-6.0.4.0 or post-6.2.0. There are no display drivers compiled for these versions yet but it’s on our radar.

yes, you is right… arnold sdk 6.2.0.1

console msg:

  • on enable addon:
    No custom OCIO config found, using default Filmic…

  • on create new material:

    …WARNING | driver_display_callback.dll was compiled against non-compatible Arnold 6.0.4.0
    WARNING | : could not set BOOL parameter “thin_walled_translucency”

    WARNING | CircularLight: could not set FLOAT parameter “roundness”
    WARNING | CircularLight: could not set INT parameter “resolution”
    WARNING | CircularLight: could not set FLOAT parameter “soft_edge”
    ERROR | node “driver_display_callback” is not installed
    …ERROR | [color_manager_ocio] Error: Loading the OCIO profile …

thks

Hey everyone!

Good news! The latest changes to the BtoA Alpha RC2 branch add support for Arnold versions 6.0.1.0 through 6.2.0.1. Because they’re bleeding edge there may still be issues that need to be worked out, but anyone that was having trouble before is now more than welcome to kick the tires.

One thing to note: I was hoping that we could let BtoA handle pointing to Arnold’s bin folder on its own, but because of how dynamic library linking works in general it’s just not a feasible, or necessarily safe, option. Instead, I recommend everyone adds Arnold’s bin folder path to the LD_LIBRARY_PATH environment variable when installing Arnold per the current installation instructions. You can then either point BtoA to the Arnold SDK by setting the ARNOLD_ROOT variable, or by setting it in the add-on preferences after installation.

2 Likes

Still getting this error when I try to enable the addon:

Actually, this error first, then the other one,

@blankblinkblank What version of the add-on are you trying to install, and what version of Arnold are you using?

Hey everyone!

BtoA 0.2.0 Alpha has been released! This alpha update focuses on bug fixes and some small new features, particularly around installation and supporting more SDK versions. If you’ve had problems with either of these in the past, give this new alpha a try. As always, please submit bug reports to the issue tracker or get in touch with us on the Discord server!

2 Likes

Heads up: there’s a reported bug that the display drivers are still not working for 6.0.1.0. This is a possible regression and known issue, and a patch will be uploaded later today. Until then, just download SDK 6.0.4.0 or later.

Super great work! Thank you so much for this project!I tried this ,works great . Just need do more work to complete it, Salute you guys~

1 Like

Hi there,

is there any chance to get on the discord server? The invitation i found seems to be invalid. I´pretty new to Arnold and very excited about it. Thank you in advance

Shoot me a PM and I’ll get you a new link this morning. It should be good forever but I’ll make a new link today if I have to.

Hi there, I guess you are Aron. This link now works fine. Thank you very much. Pretty exited :slight_smile: