Array fit curve not working as expected

I have searched the forums and found partial answers to this but I can still not make it work correctly. I am likely not doing something blender requires. I have applied an array AND curve modifier to a mesh. The mesh follows the curve when the array is set to “fit length” and “fit count” but balks at following the curve more than a few iterations if I choose “fit curve”. Both the curve and the mesh have the identical origin point and there has been no translating separate elements in object mode. I am attaching an example file showing fit curve and fit length using identical elements. What is the secret here?
Thanks!

array curve issue.blend (460 KB)

It is because you have an un-applied scale on the cube. Press ALT-S to clear the scale and you will see that the array does fit to the length of the curve. If you apply the transform (Under Object/Apply/Scale menu) you will get the same result as the other cube & curve setup.

Thanks Atom, that works perfectly. I am not sure why but just one of those things Blender requires that is obscure before a knowledgeable person reveals the secret! :slight_smile: