Array fit to curve still not working

I know this has been covered before but it is still not working for me.

I have a mesh that I want to repeat along a curve. I have applied fit to curve with no result other than an appropriate number of clones in a straight line. I have applied scale to both the curve and the mesh. I have also tried applying a curve modifier beneath the array modifier. This results in the mesh following the curve but is then distorted by the curve. My goal is to have the mesh object repeat along the curve without distortion.

I have attached a file showing 3 atempts

  1. fit to curve only
  2. fit to curve with added curve modifier
  3. fit to length with added curve modifier



array curve issue.blend (460 KB)

Like this? .blend


With the curve modifier, the angle and position of the object is critical, so you may need to edit it to get it aligned as you need to. Good video to watch:

He has a problem with the curve modifier deforming the mesh, not how to get it to work.

I guess, i remember the therm “Curve Deform modifier”…
In any case “simple but efficient method of deforming a mesh along a curve object” is what rtfm says so that this shouldn’t be a surprise that Curve modifier deforms something along ;).
Cheat this by increasing complexity.

Thanks for all the info. Ognjen has an interesting solution using dupli-frames with no modifiers. As to the youtube video it is helpful, I have seen it before but happy to look again. I just find it curious that when you use a curve modifier with the array it does not seem to make much difference in terms of result, whether you use fit curve, fit length or fit count. It makes me wonder what good is fit curve. If it worked as expected (painlessly repeating an array along the path of a curve) it would be great, it just doesn’t.

Thanks again to all, I appreciate your time

“it just doesn’t”… Have scales applied?

As Eppo says, your scale is wrong. On your ‘fit to curve’ example, ctrl+a set scale, then set your offset to 1.0 exactly. You will see that it fits the curve perfectly. Now, the reason it isn’t fitting it perfectly with an offset of 1.5 is that basically, you have shifted the goalposts as it were. Set the offset to 1.540 and it does fit the curve exactly. It depends on if you want it to fit the curve exactly, or you want the offset to be 1.5, you can’t have both, unless you alter the length of your curve instead.

1 Like

YESSSSSS!!! Guys if someone is still having this problem after these replies as I had…I finally found a solution and am very excited to share it … :star_struck: :star_struck: :star_struck:

Make sure
scale is applied (both curve and object)
both the curve and object are at same origin
(And here comes the magic…!!!) :mage:
select curve >> go to edit mode and click N to bring up the right tab (Idk it’s name) in that the curve radius won’t be 1 if your object is deforming >> turn it to 1 and TADAAAA…
Everything looks gorgeous :heart_eyes: I had this problem for centuries happy to finally find a way…if you want to say thank you come to Instagram @devil_on_details…I am glad to help :smile:


You are a life saver. I’ve been struggling for 3 days in a row for this option.

I was looking for a solution, and your answer was the best! Thanks!

Thank you!!! My issue required the mean tilt in those settings, getting the correct rotation of array object!

This fixed my problem. Thanks a lot.