Artifacts after removing edge loops / un-subdivide

Hey guys,
I’m currently working on an object on which I have to reduce the polycount. Therefore I’m removing some edge-loops on detailed round objects like pipes etc.
But I’m encountering a strange problem: After I remove the edge-loops or Un-subdivide it (i just discovered this function), the faces have some strange artifacts, as you can see in the pictures.

At first I thought this has something to do with normals, but they are all outside and there’s no duplicate geometry underneath the faces. The shading is also set to flat faces, so that should not be the problem, even if it looks like that.
Basically I’ve tried every step under the Mesh Cleanup-Tools, but that didn’t help.
Could non-planar faces be the reason? And if yes, how do I repair them?

For some reason the problem can be reduced or sometimes completely solved, when I add a basic cube and join it with the mesh. Can anyone explain, why that works and if you can do it in some other way?
Thank you!

Seems like a custom normals problem. Try selecting the object and in search (space or F3) use the command “clear custom split normal data”


Thank you Lillya! That was the solution. I’ve never heard of this function before and I couldn’t find it anywhere in the menus. Is there any other way to find it, except the search function?

It is in the Object Data Properties tab, under the Geometry Data section. If there is a custom normal data it will show you the option to clear it.

Also in edit mode, you can go to the Normals menu (alt + N) and use the reset vectors option, it seems to do the same thing but you can choose only the faces you want to reset.