Artifacts on EEVEE render

I’m rendering an oil animation in EEVEE, but the final images have artifacts in them.
I’ve played around with the render settings but didn’t manage to get rid of them.

Any suggestions?

I do a brightness/contrast and saturation boost in the compositing, but even without it I get the artifacts.

This is known gradient issue, when meet 32/16-bit to 8-bit conversion. Try “Output Properties > Post Processing > Dither” 1.0 or 2.0.

1 Like

I tried it, but it’s not making a lot of difference.

Dither 2.0

Dither 0

This is enough. Images are 8-bit, don’t forget this.

I rendered it at 16bit depth but I still see the artifacts.

So I can’t get a better result other than rendering it at 200% and scaling it back?

Rendering with cycles instead of eevee solves to problem.

That’s not really a solution for Eevee. Could you share your scene here?

Yeah sure, you should be able to download the file here: https://drive.google.com/file/d/1ZN7hmFd154QDe6FGwzYHaCNI8SMUOGdU/view?usp=sharing

I fixed it by using the bilateral blur node to blur image while retaining their sharp edges.
It quintuples the render time but is still way faster then cycles.