"Auto Perspective" doesn't work with top-down User Orthographic view?

(Edit: I think I described the problem much better in a follow-up post down below this one, sorry for the confusing initial explanation.)

This is driving me crazy. Please bear with me while I explain my issue. Let me know if my description isn’t making sense and I can record a video to show my issue more clearly.

I come from 3D Coat so I was very happy that Blender has a similar way to snap to orthographic views. I use middle mouse to rotate the camera around to about where I want it, then hold Alt until it snaps. I’m aware that I could hold Alt THEN move the mouse to snap to orthographic views, but I prefer the first way because it gives me more control over what angle I’m viewing my scene from when I snap to orthographic view.

This all works flawlessly except for one issue. I frequently snap to top orthographic view to move stuff around in my scenes. As long as I snap to top orthographic on a cardinal angle, I’m good; the mode is “Top Orthographic” and the Auto Perspective option snaps me back to perspective view when I rotate the camera.

However, I often snap to top down orthographic view at a 45 degree angle without even meaning to. This is actually nice because again, it lets me view my scene from the angle I choose. However, the mode is labeled as “User Orthographic” instead of “Top Orthographic”. Therefore, when I rotate my view, I stay in “User Orthographic” mode and have to hit Numpad5 to go back to regular perspective mode. Curiously, it’s only the 45-degree top-down views that are affected by this; the 45-degree side angles don’t put me into “User Orthographic” mode.

Is there ANYTHING I can do about this? The camera system is almost perfect, but I’m constantly accidentally snapping to “User Orthographic” mode when going to top-down view, and then when I want to rotate back to normal camera view I find myself stuck in orthographic mode until I hit Numpad5. Why isn’t the 45 degree angle top view also considered “Top Orthographic” (as opposed to the cursed “User Orthographic”) so that it can affected by the Auto Perspective setting? Or why can’t I just disable these 45 degree “User Orthographic” angles? I don’t want to go into User Orthographic view unless I choose to by pressing Numpad5! I wish I could disable the ability to snap into “user orthographic” mode with Alt+MMB because it’s really screwing with my workflow in Blender.

Your dilemma is hard to understand. What button presses get you to this User Orthographic mode?

NUMPAD 7, and then …
The only way I can do it is SHIFT + NUM4 or SHIFT + NUM6. Just change those key bindings if that is the case.

Thanks. I figured it would be hard to describe. Here’s the issue. I hate using the number pad to go to ortho views for a variety of reasons, most importantly because I don’t want to have to move my hand all the way over there constantly. Instead, I use Alt key to snap to orthographic views. You know how you can hold Alt and the middle mouse button and then swipe in the direction of the orthographic view you want? There’s another way that I haven’t often heard people talk about, which I strongly prefer and want to use. It works the same way that snapping to ortho views in 3D Coat works, if anyone has used that (except in 3D Coat you use the Shift key instead of Alt, but anyway…) Basically, you use the middle mouse button to rotate around toward the view that you want to see in ortho, THEN press Alt and it will snap to an orthographic view. This is way better to me than using the number pad because I can just rotate toward whatever view I want and hold Alt and it snaps.

This is great, but there’s a really weird issue. Try using my method to snap to top orthographic view. It works great… but wait. The issue is that there are a few different ways that it will snap to top orthographic view. If your view is close to being lined up with the world grid, it will snap to “top orthographic” (and that will be the mode it shows on the label at the top left of the screen). But if you aren’t lined up with the world grid when you try to snap to top orthographic, you’ll get “User Orthographic” and you’ll be viewing the scene from a top-down view, but at a 45 degree angle.

That’s all fine and good. The problem comes after you accidentally snap to “User Orthographic” instead of “Top Orthographic”. Because when you try to rotate away from that view, you’ll be stuck in “User Orthographic” mode (aka the mode you get into when you press Numpad 5) and you have to go over and press Numpad 5 to get OUT of User Orthographic mode. But I never intended to enter User Orthographic mode in the first place! I just wanted a top orthographic view, and I want the camera to jump back to perspective mode when I rotate it.

Does that make sense? If not I can record a video.

Makes sense. I didn’t know you could use ALT like that.

I might suggest binding switch iso/persp. from NUM5 to SHIFT + mousewheel, that way you can easily get back to perspective.

Disable auto prespective

One thing you can do is “re-snap” to say, front orthographic, then middle mouse out of that and you should be back in perspective view.

Yeah, I’ve tried this, but I WANT to be able to snap to orthographic. I just want this one stupid 45-degree angle to stop throwing me into User Orthographic mode. It’s infuriating. I understand it’s a bit of a niche issue that maybe only affects my quirky way of using Blender, but yeah.

The thing that drives me crazy is that the Auto Perspective checkbox works exactly as intended for all other orthographic views, putting you back into regular perspective view as soon as you rotate the camera. But these stupid top-down 45-degree angles are messing the whole system up because they don’t function like other orthographic angles.

Thanks for the reply regardless!!

True, that does work. It’s still an annoying extra step that throws off my workflow. Oh well, I understand that I probably have a very niche way of using the Blender camera. Thanks for the reply!

Thanks, that’s one idea for sure. I still wish there was a way to disable this stupid 45-degree angle that throws me into User Orthographic mode when I don’t want it to. Ah well!

I wonder if it would be possible to write a script to simply DISABLE User Orthographic mode? Or at least recognize when I’m in User Orthographic mode and kick me back to User Perspective mode automatically? I don’t use User Orthographic. I use straight-on orthos of course but I have no use for User Orthographic view.

Of course I’d strongly prefer if these stupid 45-degree angle top views didn’t put me in User Orthographic mode, or they simply didn’t snap with Alt. But I’ll take anything I can get because this issue is really messing with me.

Dang, you’re right, I never noticed this. I wonder if this counts as a bug. It definitely looks like an oversight at least.

1 Like

Hmm, maybe I’ll make a quick video to show the issue clearly and report it as a potential bug/oversight. Thanks for the reply.

1 Like

One thing you may not be aware of is Quad View CTRL ALT Q, that includes all 3 ortho and 1 persp.

But there are at least 2 or 3 potential fixes: one is to mark certain User Orthographic views as being TOP, SIDE, etc. so that the program knows to go back to Perspective

the other is to not snap at all to User Orthographic and only Top Orthographic, etc.

and last is to not snap to User Orthographic, but rather User Pespective if the snapping is not done at 90 deg intervals

and maybe the least desirable: not to have that ALT snap type at all and only the ALT + MMB rather than MMB + ALT