Auto run disabled

Though I never had any problem with this. I so often saw this on the top of the window.
What is this Auto Run Disabled​…?


Python scripts loaded by a blend file do not run automatically. It is a security measure, since a python script can literally do anything with your computer when you run it. You can change this in the User Preferences file, or you can find the python script in the Text Editor window and press the Run Script button.

It may or may not give you trouble: some scripts are built in. But if you get that message, it signals that something Blender needs for some function is not available because a script did not run. If you don’t use that particular function, you won’t notice the lack.

Rigify is a particular case where lack of its script causes a lot of strange and unwanted behavior.

Since recently, there’s a new option in the User Preferences, on the File tab: “Auto-run Python Scripts”. As its name suggests, when this option is disabled, all the scripts included in a blend file is loaded but not run when the file is loaded… unless you activate the option “Trusted Source” in the file selector.

This is supposed to be a safety measure in case somebody would be stupid enough to include some malicious code in a blend file… and to wish to become a pariah in the community instantly.

Alas, to prevent the auto-run of the Python scripts also breaks the drivers. That’s what Blender complains about on top of your screen.

Instead of disabling this option, I suggest to keep it enabled and to never, ever download a blend file from a shady website, even if malicious code has never been found in a blend file… yet. I guess it’s planned for the day Blender will have crushed all its competitors and will become a target for the nasty hackers. :wink:

EDIT: Orinoco beat me on the finish line…

Thank you Kaluura, whether ORINOCO beat you or not I am not sure…:slight_smile: but both helped me a lot

Thank you ORINOCO… it helped me a lot