Background hdri not showing up in cycles render

I believe I have looked at pretty much every related thread on the net and I am stumped. I have tried a number of HDRi’s (using nodes - environment texture) but I deleted it from this file as I couldn’t upload it due to size constraints.

The problem is that I want to be able to see a HDRi through the window so there is a backdrop of some sort. Whether the window (with glass) is there or not makes no difference: it renders as black in cycles. (I used the node setup from a blender guru vid). I imagine that I must have somehow turned something off in the early stages. The light from the HDRi seemed to be OK - my first render was with it set to transparent and I’ve tried toggling that option a number of times with combinations of other options (ie ray visibility/camera). The HDRi is visible in the viewport - I’m using perspective view (but I guess that should not affect the render anyway?)

Going in circles so now I’ve come pleading for help.

Thanks in advance :slight_smile:

bathroomQ.blend (3.9 MB)

You don’t have an HDRI set up as the background in the world tab, nor indeed do you have any world settings.

Thanks for you reply and taking the time to look at the file Roken. I mentioned in my question that I had removed the hdri to try to get the file size down. I believe the problem is slightly more difficult. It does not work in my original file (which is 122MB). When I delete a whole bunch of assets to get the size to 5MB it sometimes works and sometimes does not. For example - in the file I uploaded earlier I re-inserted the hdri and it worked! I tried deleting and reinserting the hdri in my larger file and it did not work. I then tried making another slimmed down version by deleting the same things and thos one did not work. All the settings are exactly identical - all I did was delete assets (that were deselected for render) to reduce the size.

World settings and node arrangement for the hdri are identical for my original file and the slimmed down version. I guess that was what you were referring to Roken?

I’m starting to think there is some sort of bug but I may be jumping to conclusions. I’ll start again tomorrow when I’ve had a sleep. Ideas/suggestions gratefully accepted.

You need a Background node between your HDRI and the World Output node.