I would like to switch my background image. I click the x under view/background, then open and then my image. But it won’t appear and that is even if I click reload. And I’m in the “3” key perspective. Any ideas…

If you have loaded you image you can only see it when the 3D view is straight on, meaning front, right, or top ortho. Hit the 1, 3, or 7 key on the key pad. IF you hold down the control key when you hit the 1, 3, or 7 key you get the reverse (back, left, or bottom)


Are you in Perspective view? If so the background image will not display. Press 5 on teh numpad to go back into orthographic view.

I have the same problem. When I first tried to use a background image in 2.47 it worked. Came back the next day to continue and no image will display. Loaded the project into the older version and there it is so I know I am doing it correctly. It simply will not display in 2.47.

= Blender 2.47 System Information =

Platform: linux2


  • Version: 2.5.1 (r251:54863, Jul 31 2008, 23:20:23)
    [GCC 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)]

  • Paths:


  • Directories:

Blender home dir:

Default dir for scripts:

Default “bpydata/” data dir for scripts:

User defined dir for scripts:
<NOTICE> – not found

Data dir “bpydata/” inside user defined dir:
<NOTICE> – not found

Default config data “bpydata/config/” dir:

  • Modules: all basic ones were found.


  • Renderer: GeForce4 MX Integrated GPU/AGP/SSE/3DNOW!

  • Vendor: NVIDIA Corporation

  • Version: 1.5.8 NVIDIA 96.39

  • Extensions:

GL_ARB_imaging GL_ARB_multitexture GL_ARB_pixel_buffer_object
GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects
GL_ARB_shading_language_100 GL_ARB_texture_compression
GL_ARB_texture_cube_map GL_ARB_texture_env_add
GL_ARB_texture_env_combine GL_ARB_texture_env_dot3
GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle
GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object
GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos
GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra
GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract
GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_Cg_shader
GL_EXT_draw_range_elements GL_EXT_fog_coord
GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays
GL_EXT_packed_pixels GL_EXT_paletted_texture
GL_EXT_pixel_buffer_object GL_EXT_point_parameters
GL_EXT_rescale_normal GL_EXT_secondary_color
GL_EXT_separate_specular_color GL_EXT_shared_texture_palette
GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc
GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp
GL_EXT_texture_env_combine GL_EXT_texture_env_dot3
GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod
GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array
GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat
GL_KTX_buffer_region GL_NV_blend_square GL_NV_fence GL_NV_fog_distance
GL_NV_light_max_exponent GL_NV_packed_depth_stencil
GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners
GL_NV_texgen_reflection GL_NV_texture_env_combine4
GL_NV_texture_rectangle GL_NV_vertex_array_range
GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1
GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod

  • Simplistic almost useless benchmark:

Redrawing all areas 10 times took 0.2648 seconds.

I notice a couple of directories are “not found”. I’ll check into that.



Does it works if instead of “Reloading” the image you try to reopen it a second time?
Because that’s what happens here, if I select a bg image it doesn’t display, then I reselect it and it works. Strange, but at least, it works :wink:

I have tried reloading, reopening. Tried a new file entirely. Nothing works. If I go back to 2.44. Works fine. I am certain that I am doing it right. I can do a workaround for modeling, but at some point I will need the background. I also found out that when I render and use a background in the “backbuf” it doesn’t display. I may just give up. I did try this on Windows XP (same PC) and it worked fine, so I know my hardware is compatible. Seems to be a Linux issue.

Thanks for the input.