background image not appearing

I’m trying to set up a background image for modeling but it’s not visible. I did end up seeing it when i looked through the scene camera though(numpad 0). It just blocks the lens. I have tried many diff angles, including the all views setting. Any suggestions?

when you have 3D view you have to turn on the right panel and then there will be a display option background images.

Background images will only show when you are in orthographic view and the specified view (front/back/right etc). Toggle between orthographic and perspective with numpad 5

Thanks numpad 5 displayed it