Bad contact shadow aliasing? (2.81)

Using the 2.81 nightly builds. I am getting very bad aliasing on Contact shadows. None of the parameters seem to help it in any way. I was under the impression from the release notes that these were getting improved, but even turning Soft Shadows on doesn’t help.

I’m trying to figure out if this is a bug, or just things being unfinished in the nightly build, or is this the new norm? Or there a fix beyond compositing shadows in from Cycles?

Could be from these recent changes:

Try increasing your samples for softer / antialiased shadows.

I’m at 64 samples right now and using a sun lamp. I tried turning up the samples into the thousands, but it doesn’t make much difference. 64 makes a difference over 8, but going higher doesn’t really.

I’ve not used it yet. Clement has discussed how to work with the new system / it’s limitations here:

1 Like

You always try to share a .blend file with the used configurations. If you do not want to share the model, you delete the model and share the .blend file with another name so as not to overwrite the original .blend file.

You use the maximum possible value in Cascade size setting (Shadows in Render tab). You can also try gradually increasing the value of “Angle” in Sun lamp settings (which is basically increasing the size of the sun disk). Of course, all this with Soft Shadows enabled.

1 Like

Changing the Angle does seem to solve most of it, but unfortunately it also changes the shading. I was using it at an angle of 0 which provides very hard edged shading, similar to using small size lamps in Cycles. I can adjust my shader though and it’ll still work.

The cascaded shadow map count doesn’t seem to impact it much in this case.


For Sun lamp, Cascade Size definitely has influence on shadows edges (you show jagged edges on shadows in screenshots). You temporarily disable Soft Shadows and try different sizes of Cascade Size and see the changes in shadows edges.
If you are also using another type of lamp (not only Sun lamp), Cube Size is the parameter to modify.

You also have Cascade Shadow Map settings in Sun lamp properties. You try Max Distance not being too big. You also be careful with Strength in Sun lamp, it should not be as large as the values you use for Power in other lamps.

Anyway, probably with Sun lamp you do not have the best result from close views of the model. You could also try another type of lamps.
If you really find that with old shadow methods (2.80) you get better results and you could build .blend files showing it, you could discuss it with developers.

1 Like

I forgot to mention about this. I think that Angle=0 is a very extreme value that does not happen in reality, and I suppose it should not be used. Also very large values should not be used.

1 Like