Bake textures


I hope anyone can help me.
I want to bake a texture but it is not working…

The baked texture isn’t leather but a pink plane???
What am I doing wrong?
Thanks a lot for helping me out

I see in your screen shot that you are baking ‘Diffuse’ only, that is the Color which is accurately presented here. If you want to bake all the shadows and such, you will need to bake out the other options from the drop down.

thanks for your reply.
The diffuse ‘color’/input is a leather texture (mixed with other stuff, as seen in screenshot). So if I only want this to be baked, I have to choose Diffuse, right? I don’t want shadows to be in the baking. It’s properly UV-unwrapped btw…
Oh…and I use Blender 2.9.1

Not sure why your texture info isn’t coming across - have you tried using BakePBR addon to see if you can get your output? I find it easier to work with than having to plug everything into emission shader to get non-shaded output bakes.