Baked Normal Map for Toon Ground Texture Not Baking All Parts of Mesh Correctly

Hi All,

I am using Blender to create some textures for a Game project I am doing, since I am a pretty poor artist. I will explain my process of what I have done, and then what my issue is:

1.) Start with a Square Plain (will be rendered to 1024x1024 image)
2.) Change camera render size to 1024 to 1024.
3.) Fit plain in ortho view
4.) Go into Edit mode and start adding/sculpting/duplicating UV Spheres for pebbles
5.) Assign Material for ground with bump map texture affecting normals
6.) Assign Material for Rocks just diffuse and spec
7.) UV Map project from view all verts
8.) New image (1024x1024) named “Normals” to bake Normals to
9.) Bake Normals to image

So the plain representing the ground looks great… the pebbles/rocks… have no normals?! Also it seems like during the bake process, the plain is generated first in the bake process, then all the pebbles and rocks are almost as another layer after during the process. Not sure if that has anything to do with this.

One thing I tried to do as well is to remove the verts from the underside of the plain if they were affecting the top-side normals… no luck.

See the diffuse and normal images attached, and I have supplied a link to the blend file.

Appreciate all the feedback and help!

Blend File:

I did not have any issues with it.

What I did with your .blend is make a new plane, scale to the same size as your existing, use ctrl - A to reset the scale, made sure they both have the same X,Y origin points and located the new plane slightly higher than the hi poly one, then in edit mode I UV unwrapped the new plane, made a new texture and named it normals, made sure the UV unwrapping is displayed, then went back into object mode, selected the hi poly first then Shift select the low poly to make it active.
In the render tab go to bake, select normals, selected to active and tangent space then hit bake. Worked like a charm.

Make sure the lo poly plane is slightly above the high poly plane.



I played around with your blend file a bit more. I think what you are doing is baking from the hi poly to itself. I was able to recreate the normal map you made by doing that. I have always learned to bake to a low poly object. f there is a way to bake a normal map by itself it is more advanced than I know.
I played around with changing the bias and distance settings, but they had no effect on the smooth areas. I also changed between object world and camera space. They would produce the rocks, but the colors were way off.
So I can’t definitively say what the issues is but it does work using the usual bake to a low poly technique.