Baked Particles with Motion Blur

Yo all,

Having a spot of bother rendering a flow of particles running along a guide curve with Motion Blur.

I have an amount of baked particles running along the curve fine, each particle is being represented by an object and that all looks fine. But if I try and render using Motion Blur, (not vector-blur), no blur can be seen.

It seems that baking these particles in this new system results in no ‘in-between’ frame information. This means that Blender doesn’t know which direction the particles are flowing and cannot apply motion blur.

I’ve tried vector-blur but it looks very ugly, yet the blurring seems to be correct, at least in direction.

Does anyone have any ideas how to get past this limitation with the new particle system? The old system didn’t require baked particles and therefore full motion blur was possible.

have you tried using Vector-blur with “Curved” On? Maybe it looks better.


I had the same problem with baked soft bodies not working correctly with motion blur. My solution to that (and it might not help with particles) was to free the bake. Then Blender seemed to calculate the motion correctly for the smaller time steps required for motion blur during rendering.

Here’s a hacky approach to take:

  1. Super-Sample the timeline, i.e., slow down the animation and simulation so that 1 frame in the old speed = 10 frames in the new speed (or more).

  2. Disable motion blur, vector or otherwise.

  3. Render the entire sequence

  4. Average each group of 10 frames together. I’m pretty sure Blender’s compositor can do this, but I know ImageMagick can, because I’ve done this exact process with the fluid simulator with amazing results. You can even weight certain frames if you wanted to, to get a nifty “blurred/strobed” effect.