Baking Stitches Geo to Texture?

Hi,

I’m trying to create stitches for my cloth. They are initially as a 3D object because they are just easier to place and manage. I want them to convert to textures through baking.

It works but not quite. It doesn’t follow the UV of the object and currently they overlap.

You can check an illustration of the problem here:

The blend file can’t be attached as it is 10mb. Here is the link instead.

Regards,
Ben

Did you realize that you don’t have texture coordinates for your stitches? Could it be that they are not in position because Blender doesn’t know where to project them? Let’s see…

No, that is not the case…

Hi @Calandro

Thanks for the response. Correct me if I’m wrong but you don’t need any texture coordinates for the stitches only for the cloth. Also the stitches and cloth will not have a matching coordinate since they don’t have the same point count :frowning:

You are right, that is why I said: “could it be”. I don’t work with baking and I really have no clue on this field, but the tests I made here let me the impression that there’s something wrong with your mesh that I cannot figure out what it is.

I made the same baking process of the stitches to another mesh and it works and from another object to the cloth and it’s messed up. So, i can say that it’s possible to isolate the problem to the cloth object. What problem it is? I have no idea.

Hi @Calandro

Cross posted this in polycount and Birb provided the solution:

You need to use a release post-May 18 or 2.91+. Check Clear Image if you didn’t already to ensure the bake won’t be contaminated with previous failed attempts then set the Max Ray Distance to a low value, eg 0.001m.

Previous versions of Blender had a misleading Ray Distance attribute which was more like an extrusion offset than anything, now it has an actual normal-based ray distance to keep rays from catching the backfaces on the other side of the mesh.

Works as expected.

1 Like

Strange that I did that on the file I downloaded here and I could not.

I am glad it worked for you, though.

1 Like

Oh, now I see… I got that result too in a point of my tests, but i thought it was wrong cause there are some stitches missing. I am just stupid.

1 Like

@Calandro
Glad to know it also worked with you :slight_smile:

1 Like