Banding-like noise on rendered explosions

Anyone have thoughts on how I might go about removing this banding-like noise from my renders (see screenshot)? I’ve tried upping the samples, but still there… using 512 Resolution Divisions, 5500 particle count, and a sampling of 256 in Cycles 2.83.

Appreciate it!

This looks like artifacts from ray marching - try lowering the step size in Cycles’ volume options.

You’ve pushed the shader density too far.

Also sometimes cubic interpolation helps a lot: