Bestguess glass

This is as far as I have gotten with glass

Im sure its not the best and any comments would be appreciated

It would appear that you need to enable fresnel? The line that is formed by the floor meeting the wall should appear distorted when viewed through the glass. IOR settings (Index Of Refraction) can be found on the net. Also, the number of reflections seems to be to few. gl. keep at it.

Thanks, I thought the Fresnel was low. but I do like the reflection, that was the effect I was going for. IOR im still messing with, but I should get a better pic up soon.


Good to hear you’re still working on the project. If you need reference material google images has like a million examples.
Can be really helpful.

I did some more tweaking with the glass and Ive come across this
I did one without shadows, but I kinda like the shadows anyways
I need to know how to do soft shadows within blender…

Hey, look at that, fresnel. Nice.

Soft shadows are a function of the lamp. Sunlight, Standard lamps and Ray traced Spots will all have hard shadows. Area lights and Shadow Mapped Spots will have soft shadows.

On the base of your glass you have a very dark area. If you increase the levels of raytrace in the Mirror Transparency panel of the material settings to match the number of surfaces that the light will have to pass through you’ll have clear glass again.

And along those same lines, the top of the goblet would appear to only have a single layer whereas the base has two or more. For more realistic looking glass two layers also on the top would be desireable. This will actually magnify the light as it passes through the glass. kewel. :slight_smile:

Good work there. A lot of fun.

Nice glass, but here’s something cool…
I had a thread exactly like this one, and then I was enlightened.
Get Yafray, enable yafray rendering (right under the render button)

Material Settings: Go to your objects material settings, go to the raymir panel (it should look a lot different). Click on the drop-down menu and select clear glass.

YafRay Settings: Go back to the rendering panel, and now there should be three tabs in the render button place. On the middle one, turn XML off. On the third one, turn depth and cdepth up to 10-12. Turn cache on. Render.

(For best effects with glass, I would advise modelling the inside of it too.

All good suggestions so far!! Definitely want to thicken up the glass probably universally thoughout the mesh just to give the light more glass to play with. Definitely use Yafray for the render, and for added fun, if you are using a spot light anywhere, make a second one in it’s place and use the photon lamp setting instead this will give you some caustic effects as well when you render.

One more thing… it would appear that the glass has some effects of subdivision without a full subsurf in the rendering… did you make sure that both of the subdivision number boxes were set?

If so did you hit the “set smooth” button?

Heres mine wine glass :wink:

Ha, ha. Yah that’s very good. I did a glass with ice in it just a while back. Took forever to render. I should’ve used Yafray too.

Unless invited, don’t post your work in someone elses thread, it’s considered hijacking or upstaging and it’s not very nice.


I was only trying to show, what can be done more, to make his glass more real.

Heh thanks guys.
Cool comments.
Ok a few questions.
As you can see, Im a noob to this forum. And so being I’ve only used blender for a short while. So Im not compleatly sure about everything. I would like to know how to enable subsurfing, and why enabling subdeviding is bad in this case… also how would I create more depth of the glass uniformally through the mesh WITHOUT copying the whole mesh, shrinking it, and then manually appling new faces…
I know in anim8or there is a “Shell” function
Is there one in blender?
Oh and nice galss dude

To enable subsurf go into the Buttons window (Shift F7, by default this one is open at the bottom when you fire up Blender) and from there go to the sub-windows “Editing” (F9).

From here it depends on the version of Blender you have.

In the Alpha versions of 2.4 (as well as the CVS ones I suppose) there is an “Add Modifier” button a bit to the right. With your object selected in the 3D view (this case that glass of yours), press that button and add a Subsurf modifier. Then I think you’ll be able to adjust the values yourself (just hover over the different values and buttons, the descriptions are pretty good).

As for 2.37 and older (but since you just got here I doubt you got anything older than 2.37) you will have a button called “Subsurf” which can be toggled on and off in your F9 window. Toggle that one on and adjust the two levels below (left for real-time subsurf and right for rendering subsurf. Don’t go too high :P)

Hope that helps, wrote it in a rush.

Thanks, I will post a new pic asap, but right now Im working on many other projects, among other things. I still need to get back to my ps2 model…