Bevel problem with Edge - extrude

The purple part in the screenshot was made using plane > edge > extrude . But I am unable to smooth the edges using Bevel / CTRL + B I tried

  1. Object > Apply > Scale

  2. In Edit mode -
    Mesh > Normals > Recalculate Outside
    Mesh > Normals > Recalculate Inside

I do not know what else to try. Any pointers will be great

Try doing a merge by distance first, it could be there’s double geometry and you can’t bevel because it has nowhere to go.

1 Like

try Colkai solution, if it doesn’t work please share your file:

1 Like

Thanks. Can you please tell me where I can find this option ?

+moonboots , thanks , I will try and update

Please check

Managed to find the Mesh > Cleanup > Merge by Distance , when tried, it solves the problem. Thanks. There is a lot of things I need to learn in Blender