Bevel weight result unexpected

I’m trying to use the bevel modifier with weight to achieve bevel on edges. My mesh here is made with boolean difference of cubes, resulting size: 0.4x5.6x9.8, as you can see in the image. I’ve set bevel width to be 0.1, and weight for each edge is 1.0. I’m expecting the result to be 45 angle like:


But the result produced by blender is weird. And rendered image shows artifacts. I’m wondering what I shall do to make bevel correct?

problem.blend (541 KB)

It looks like your geometry is not clean to begin with; faces flipped, double vertices, faces not connected and such. That is why you are seeing strange behavior.

There is no need to use Boolean to create simple geometry any way. Do practice building it. Here is my frame:

It is made from cube. Scaled to rectangle [S]. Made cuts [Ctrl][R] to frame the edges and center beam. Erased, Select [X], faces and bridge the openings. For bevel I just made loop cuts [Ctrl][R]; highlighted edges. Lower opening is finished by Merge vertices [W].

@ridix, thank you very much for the pointers. I’ve managed to recreate the frame with cuts and extruding.

Bevel modifier with weights appeared to be working, but it’s still not 45 degrees. I’m not sure why, but I’ll continue creating the bevel with more cuts.

Bevel modifier with weights appeared to be working, but it’s still not 45 degrees
You may have scaled your object in object mode which will change the axis scale. Having differerent scales for each axis will cause problems. Either scale in edit mode or in object mode reset the scale with Ctrl+A / Scale

@RichardMarklew, thank you very much. That did the trick.