Bezier curves

I am trying to make hair that looks realistic and that can be animated. I think ill be using static particles guided by a curve, ill then add a softbody to the curve to be able to aply realistic wind forces. What i am stuck on is the gravity thing. I want the hair to fall down, logically, but to do so i need to have a vertex on the curve with a weight 1. I dnt know how to add weights to the curve and without it the whole thing just falls down

Could anyone please tell me how to add weights to the curve?

Thank you

You can only set weight with NURBS.


i wasn’t aware that softbodies could be used in conjunction with bezier/nurbs.

is this true? in some quick experiments i just ran i was able to assign a softbody modifier to both a bezier and a nurbs curve, however, running the simulation after adding gravity and playing with the other parameters had no effect.

so for now i’m going to assume that it isn’t possible.

i was able to get the curve to act with gravity and wind, but the whole thing moved because i couldnt get a weight on it. So to do it you must click on the button ‘use group’ so that it doesnt use a group, or just set the spring to 0

To add weight to a curve, select the individual vertices of the curve, and hit the “w” key, and then select Set Goal Weight. I’ve used this in some softbody hair tests. If you don’t have the latest CVS, you might want to download the Release Candidate version from here:


edit Under the softbody settings for your curve, be sure to select the little “W” button. 8) Also, I would recommend using the Path curve.

i have the 2.4 alpha2 version, the w key brings upa special menu, will the version make a difference?

If you don’t have the little “W” button under your softbody settings, then you’ll need a more recent version.


problem solved. You have no idea how happy you just made me…thank you very much!!

works for me too. turns out i just needed the release candidate.

Not sure if I’ve missed something:

Made a nurbs curve - OK

Enabled it for softbodies - OK

Turned on the “W” button for lattice weight - OK

Tried to apply weight to individual vertecies using WKey-> Goal Weight with singel vertex selected - Not OK - Sets weight for whole curve, not single vertex.

How do I set the weight of a single vertex in a nurbs curve?
(Using 2005-11-27 test build)

Don’t worry - Found a Set Weight button in the MeshTools buttons for Nurbs!

if you have the latest ver of blender it works fine. try to use a bezier curve or a path, select a single vertex and press w, set goal weight to 1. Then you apply a softbody, select ‘use goal’ and the ‘W’ button next to it, it should then work like magic.

The ‘set weight’ button for nurbs on the tools menu is to set the weight for a verteex for using to fomr the curve, not for softbodies, it only give it a weight in bending the curve, ie if set less, it will be affected les, so there will be a straight part or sharp corner