BGE press P and object invisble or messy


why bge my image invisble or messy in blender game ??
but in blender render the image is perfect ??

need help and thanks :slight_smile:

Ensure your materials do not have Transparency enabled.

@monster : thanks for your reply (y)
the Traparency has solved but it looks like better then before

but when i press p the mesh shape is different before i press p .
confiused -___- this my first game but in 3d image has a problem :frowning:

This depends how you deform your mesh. Not all options are supported in the BGE. Please post a demo file, that we can look at.

but when i press p the mesh shape is different before i press p

bigger/smaller? do you scale your object in edit mode or in object mode?

edit mode is the best way to do.
to give the object it’s origional size back you should be in object mode, select the item then hit als+s then alt+r.
now the scale is set back to it’s origional scale and the rotation is also back to default (s = scale, r = rotation)

when you done that hit p and see if they still get smaller/bigger, if not then you can select the object and go to edit mode and scale/rotate it inthere. and your problem should be fixed.