Big problem after upgrade to v2.82 and one smaller one

I just updated from v2.79 (maybe 2.79). A 3D print file I have been working on forever with 2.79 was saved with a majority of the objects hidden (H). Alt H does not make them visible in the new version.

Also, the default dimensions are in meters. How do I change that to mm?

I loaded the file on to another PC that has an older version 2.78. The hidden objects are still there. So how do I make them appear in the new version?

Viewport visbility

Hello! Viewport visibility is a bit different on 2.8x. There are two kinds of toggles now, global (display icon) and current view only (eye icon), so the first thing you want to do is enable both to be able to check the visibility of your objects.

To choose which toggles display in the 2.8+ outliner click on the filter icon. Once enabled check the visibility of missing objects.

(ignore the arrow on the camera toggle, I borrowed this screenshot from another answer of mine)

Regarding the shortcut, there was a change in 2.8x and the keys involved in viewport visibility might be included in this. I advise you to check the new keymap and adapt it to your needs. It can be found in Edit > Preferences > Keymap.


Units are directly linked to each file. They can be changed in Scene Properties > Units.

To make it a bit more “default” you can edit it in your startup file. Create new file (Ctrl+N), change the unit then save it (Ctrl+U). From now on all projects created using the startup file will have the desired unit.

Figured out the units thing. Thanks!

I don’t have the filter icon like you do. I must have something turned on or off.

No longer panicked. I know the missing parts are temporarily in an alternate parallel universe.

Finally figured it out. What a pain.