Big shadow artifact on 3D text


I’m trying to render text for a title, however I quickly noticed an unusual shadow in one of the letters. A very black, solid shadow. No matter which light orientation I choose, the shadow stays there. It eventually changes when I move the camera somewhere else with different position and orientation, but the orientation I want gives this horrible artifact…

I’m using the Cycles renderer with an emissive quad above my text. Converting the text to mesh didn’t change anything.

Here is the blend file, the artifact shows only when rendered: shady_troll.blend (622 KB)

Is there something I missed? Is it a bug?

Yes. No. It’s you using smooth shading on a mesh with large flat areas. Following your command Blender treats those as smooth, too, thereby creating shading artefacts.

Check “AutoSmooth” in the Object tab for the mesh.

Ah, yeah, that fixes it!

One small problem though: I never asked Blender to make it smooth everywhere, it was set automatically I guess.
In my local project, this mesh isn’t a mesh, it’s a 3D text, and it doesn’t have an AutoSmooth option (I sent it as a mesh here because it’s an uncommon font).

Do I really have to convert it to a mesh?

You can use the Edge Split modifier with fonts: Adapt the split angle to your liking.