Black area when rendering in cycles

I’ve been trying to render an object in cycles using a HDRI set up and keep getting a black area toward the back. I’m using a metal PBR shader (from blender guru). It seems only at low angles it appears. from a higher view it is OK.

Thoughts on how to get rid of it?


The last time I saw a similar effect I solved it by adjusting the light path settings in properties. In other words something is limiting your rendering.


Thanks for the tip Lux. I tried playing with those and a several other settings throughout blender but nothing.

Anyone else have thoughts?

Could you share a .blend file where the problem appears? If you do not want to share the model, you at least try to isolate the problematic part and share it.
http://pasteall.org/blend/

I think I found the issue. When I have the model set to smooth shade the issue appears. When I set it to flat shade it goes away. So I separated the top surface and set it to flat and everything else to smooth. So far it is work. Not sure whey it did not render properly even when set to smooth.

Let me play around with this a bit and if I have any other issues I will then upload a file.

Thanks for the help.