Black Background in Cycles

Why do I get a black background (rather than a transparent one) though I untick the Use Environment under Render Layers panel?

Render / Film settings enable ‘Transparent’

When you save your image ensure you are rendering to a file format that supports transparency and enable RGBA

I did it but it didn’t work. I changed it from RGB to RGBA and the background is still black :frowning:

Upload blend file to and tell us the download link

Sorry 4 being late…

Opened your blend file and Transparent hasn’t been enabled or RGBA set as I’d suggested previously.

When I do that, render, saved the image and open in PS I get:

Look, I am talking about the Use Environment button under the Render Layers panel (so I can CHOOSE which layer should have a transparent background), not about the Transparent button under the Film panel which makes ALL layers have a transparent backgrounds…

If you want any render to have a transparent background you need to enable Transparent.

If you want to use the background in your composition just use the Environment pass or use different scenes with and without transparent enabled