.Blend file is stupidly big.

(TheANIMAL) #1

I’ve got a .blend file i’ve been working on for ages, but because of its size, its becoming a bit unstable ingeneral, whatever i do, the amount of memory it uses, to even do simpe things is becoming so large that i do ten things, then save, exit and open it again, because blender will crash if i carry on for more than 5 minutes. The computer i use for blending has 1 and a half gigs of RAM, and the file size is now 132megs. I’m pretty sure it has no reason to be that large. At the moment, just saving without altering enything adds another megabite to the file size and i’m pretty sure intotal it doesn’t need to take up more than a hundredmegs.

This happens to be my Star Destroyer project that i am still working on. Any reason why this is hapenning, and how can i get the file size down a bit?

0 Likes

(Myke) #2

Well, usually you can’t. Could you elaborate on what the file contains? Only geometry or also packed textures or something? But judging from the bit you tell us about, it seems like you just have a huge load of vertices? To work better with a high-poly model you could try to split it up into several parts, put them on different layers and work on these seperately. Or hide unnecessary vertices or try to use modifies like array (which should be possible if it is something as technical as a Star Destroyer).

If it isn’t the vert-count…then I’m not really sure how to reduce file size. It does seem weird that it just gets bigger if you save without doing anything, let’s hope it is not corrupted or something.

0 Likes

(TheANIMAL) #3

Yeah, its not a miss management of polys, i’ve got pretty darn good at doing that because i dont think any of my last 5 projects have had less than a million in each.
There are about four million in this one, but none are doubles, i know i’ve played around recently with things like user prefrences (to reduce the memory usage ironicly enough), and there are 60 lamps, but still, just playing around with textures and lighting, and we are talking pretty basic stuff, has added another thirty megs.

Edit: I’m getting paranoid, it doesn’t do it for no reason, without doing anything, just repeatedly saving it, the file doesn’t get larger, but moving stuff around, or changing a value of something, then saving does add size to the file. If you change something back to how it was before, it will still get larger, see the problem?

0 Likes

(Duoas) #4

It sounds like you’ve got a memory leak somewhere.

There used to be an option to keep unused datablocks around, but I can’t seem to find it now…

In the preferences window, edit methods, make sure you are linking materials to the object data and not the object itself. Likewise, make sure you don’t have material, texture, or ipo duplicated with the object.

That’s all I can think of to cause the problem on your end (but what do I know?).

To unload some stuff, have you tried opening a new blend and appending the parts you want to keep from the old?

I don’t know if this will help or not…

0 Likes

(TheANIMAL) #5

Never heard of a memory leak before, sounds pretty strange, and in a release of blender that is supposed to be a bugfix release. The only thing i can think of that could have caused this is that somethign happened to the file when i swapped from 2.44 to 2.45.

To unload some stuff, have you tried opening a new blend and appending the parts you want to keep from the old?

Sounds like the only good idea, but it’ll be a hell of a mission, almost all of the meshes have the mirror modifier, there are loads of light sources, and seven or eight material and texture setups, and some nodes work, and i’ve still got to figure out what happend a while a ago when the rendering went wierd when i used default UV for such a high poly mesh, but it sorted its self out. sigh

0 Likes