Blender 2.47 camera choice for rendering?

I just loaded 2.47 on an “extra” computer here at work, and I’ve been fooling around a bit with a scene I created at home. I have 2 cameras in the scene, but when I render from either camera I get the same view, that of the second camera. I’ve cntrl-0 selected the original camera, when I do the camera view it shows the correct view for the camera, but when I render it’s the view from the other camera. What am I missing?
System is Win2000 on a reasonably competent PC. 4G RAM.

Hmm, two cameras seem to work as expected for me on 2.47. I select the camera I want to render with, then press cntrl-0. It brings up that camera’s view and when pressing F12 it renders that camera’s view also.

You could always use the “Render this window” button on the bottom of the 3D Viewport through the camera’s perspective if you just want to test it out.

View --> Cameras --> then select Camera you want to be active

Could it be that you copied the camera from each other and also copied an ipo by accident?

EDITED: Upon reading your post again I think Rhoemer is right. Just because you are looking through camera in your view port doesn’t make it the default for rendering.

I didn’t copy the camera, I inserted it via spacebar>etc. All the cameras in this particular project are stationary so far. I’ve tried selecting it via the menu as Rhoemer suggested, that doesn’t work either. I tried adding another camera, which shows up as Camera.002, and I can select it and view from its POV but it still will only render what Camera.001 sees. I’ve done a “save as”, made sure the file was on my hard drive instead of the USB drive I used to transfer it. Very strange. I had v2.45 on this machine previously, could there be something left over that’s messing up 2.47?

delet all cameras and start over

It’s possible that the view you’re seeing the camera view in isn’t “locked.” There is a lock button beside the layer buttons. If it’s enabled, then the renderer will use that view’s settings for rendering. If it isn’t locked, well, it won’t necessarily.

There is also a built-in script that allows you to change cameras.

As an aside, the “active” camera is the one with the filled-in triangle on top. When the Lock button is on, it is also the render camera.

That did it! It was the unlocked lock button that locked me out of my camera.

Thanks, all!