Blender 2.48 (x64) + YafaRay 0.1.0 = Not working?

Hi there!

I’ve read through many posts trying to find a solution to my problem. The case is this:

I used to have Blender 2.46 and older Yafray 0.0.9 and they worked together correctly. Now I installed (or extracted to be precise) the new 2.48 64-bit version of Blender for Windows Vista (I have Vista Premium 64-bit). After this I installed the new Yafaray. Here’s a picture describing the situation:

  1. I installed the following packages

  2. I got this message when trying to use built-in Yafray renderer (and also tried the export thing, which led to that kind of situation shown in the picture)

  3. Even though I ran the yafray installation in the administration mode, it didn’t create the registry value to the folder shown in picture (which I manually added, as told in many posts throughout different forums). INSTEAD, however, the Yafray Team folder was created to the following directory: HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/

Why did it install it to that folder? And why my manually added key does not solve the problem that Blender won’t find Yafaray?

I’m pretty confused with this problem since I’ve tried to uninstall and install different versions of both Blender and Yaf(a)ray, and nothing seems to return it to the situation where it used to work.

So please help me If you can!

I have the same problem. I hope someone can tell us how to install it correctly.

You need to install Python 2.5.2 too (as the console hints at with the message “No installed Python found”. Install it and things should work much better.

Niska, btw, do join at the freenode network :slight_smile: There are many Finns there (and me :wink: ).


Well, you’ll have no luck with 64bit Blender because YafaRay Windows binaries are not 64bit. No amount of manual fiddling will change the fact that 32bit libraries won’t run in a 64bit process…

edit: Now I got the 0.0.9 and Blender 2.46 working. Now I’m waiting for a 64-bit version of YafaRay… :stuck_out_tongue:

I got similar problem - I get “Couldn’t find registry key for yafray, is it installed?” I installed it more than once as well as Blender. Any ideas what is going on?

I wonder when people will get to know this:

Do NOT mix 32bit and 64bit!! It will never work!


And “you have to install Python” actually means “you have to install Pyhton 64bit”!


A lonely 64bit Windows plattform manager :wink: