Blender 2.56B crashes on startup

I’m running windows XP 32-bit with SP3 with a 3.39 GHz processor (single core, threaded), and 1.25 Gigs of RAM. I have administrator privileges, and Blender is installed in “C:\Program Files\Blender Foundation\Blender”

I’ve tried running blender 2.56B without success.
I get the error: “The instruction at ‘some hex value’ referenced memory at ‘another hex value’. The memory could not be ‘read’.”

I’m able to run 2.49 (or whatever the latest stable release is), and I have python 2.6 installed.

I tried installing python 3.1 to see if blender would work successfully, but no go :spin:

I’ve also tried this with no programs running, and with the zip version.
When I run the following:
“blender.exe -d”
in command prompt

The following text appears before I get the memory error:

Blender 2.56 <sub 0> Build
Build: 2011-01-04 23:31:09 Windows:32bit Release
argv[0] = blender.exe
argv[1] = -d
read file
   Version 255 sub 1 svn r0

swin 1 added
swin 2 added
swin 3 added
swin 4 added
swin 5 added
swin 6 added
swin 7 added
swin 8 added
swin 9 added
swin 10 added
swin 11 added
swin 12 added
swin 13 added
set screen

Please help, I really want to get started with 2.5 :smiley:

EDIT: No one can help? At all? ):