Blender 2.57 User preferences and the console (windows 7)

Hi all…

So I just downloaded the nicely fresh Blender 2.57 version… and ran into two minor issues.

  1. I wanted to keep my user preferences from 2.56

  2. I wanted to keep my console open (is now hidden by default).

For those who come across the same issue… here’s how I solved them.

  1. Getting your old user preferences back.

The first time you load 2.57, in the startup screen you have the option to get your old preferences, and use them for this version of blender… Naturally like me… you didn’t click on that, and the chance has passed you by.

Remove the 2.57 user preferences from the AppData folder. On windows 7 you can find them in: C:\Users\username\AppData\Roaming\Blender Foundation\Blender (and have username as your username).

Then reopen blender, and in the popup… tell it to load the old preferences

  1. Keeping the console open.

Now in 2.57 the console is hidden/closed by default… which for most people is great… But since I’m doing a lot of python scripting I rather like it open. You can open it from the help menu: Help/Toggle system console. But that only opens it once and doesn’t keep it open next time you open Blender.

What worked for me is… I edited the shortcut in my taskbar to read:

“C:\Program Files\Blender Foundation\blender-2.57-windows64\blender.exe” -con

Adding the -con tells it to keep the console open… and make sure the -con is added outside the “” or it won’t work!

It would be nice if we could have this as a preference in the regular blender user preferences… but as a hack… this works as well :wink:

I hope that helps!

got same problems

1 - User preferences
i missed the warning in splachscreen
so i open 2.57 then save user preference with Ctrl-Z to create a new folder in :\Users\username\AppData\Roaming\Blender Foundation\Blender (user area App Folder)
then i copied my old Start file from 2.56 to 2.57 folder and now that works fine!

2 - Con
i hope there is an RNA var somewhere that we can be changed and that somebody will find it and tell us how to change it !

by the way when i open up 2.57 i can see the con window open on the bottom header but then it goes away! so there must be some var to control that !

to get the console back press space then search for “console” the first option(toggle system console) should let you toggle it on/off

The problem with that is that you have to invoke this command each and every time you start Blender to get the console back. Macouno’s solution is better for those who like to keep the console open all the time, because it will force it to be open and stay open every time Blender is open.

To open your blender with console by clicking blend files, you can change the open command in your windows registry:
-search for ‘regedit’
-open HKEY_CLASSES_ROOT
-search for the entry ‘blendfile’
-shell -> open -> command
-and change this key to:
“C:\Program Files\Blender Foundation\Blender\blender.exe” “-con” “%1”
or just add “-con” to the previous value

i tried to change the shorcut and added - con at then end of line in shortcut but
it does not like it on Vista 32 bits!
i can see beginning of blender window but then wait and wait and nothing happen !

any one knows why and how to correct it ?

If there are spaces in the path to blender.exe there have to be quotes around the path… Do you have that… check my example at the top… I haven’t tried on vista though.

In XP, putting the following line in the Target text box of the icon properties works:

“C:\Program Files\Blender Foundation\Blender\blender.exe” -con

Note the space between the last " and the -con

Thanks so much for that hint!! very useful

Hopefully this:

Keymap fix: Brecht, Campbell & Ton had meeting discussing how this system would become reliable for both usage as save/load and add-on cases. Ton writes out proposal.

will straighten things out in future versions. Thanks for the tips macuono, I was wondering how to get my settings back