Blender 2.62 r44136 User Preference Problem

Greeting everyone,

I am new to this and have just downloaded the newest version of Blender to my laptop to give it a whirl. (Moderator, please move the the appropriate area if not posted correctly!)

After watching numerous beginner tutorials I have begun to navigate the User Preferences menus. Most “tabs” react immediately and load the appropriate configurable contents, however when I click on the “Systems” tab, Blender goes into a “Not Responding” state and hangs. (I’ve left this hang for up to an hour, thinking Blender/Python might be scanning the system to create parameters. I had to force-close the application after waiting.)

I am running Blender on a new HP Envy17-3D Laptop with Windows 7 Home Premium 64bit. I have downloaded and installed all the newest updates and drivers for the machine.

I’ve tried load Blender using the stand-a-lone 64bit ZIP method and then tried it by installing to the machine using MSI 64bit installer after discovering the problem. I end up in the “Not Responding” situation in both methods of running Blender when I click the System tab.

I run Kasperskys Internet Security Anti-Virus and after checking the settings, I find that Blender is a trusted app and should give access to system setting and should not be the problem.

Any ideas why this is happening, or is Blender just not compatable with my laptop?

Summary of Laptop specs

Operating System
MS Windows 7 Home Premium 64-bit SP1
Intel Core i7 740QM @ 1.73GHz 78 °C
Clarksfield 45nm Technology
8.00 GB Dual-Channel DDR3 @ 659MHz (9-9-9-24)
Hewlett-Packard 1590 (CPU) 76 °C
Generic PnP Monitor 1920x1080 pixels
ATI Mobility Radeon HD 5850 (HP) 74 °C
Hard Drives
977GB Western Digital WDC WD10TPVT-65HT5T0 (SATA) 41 °C
Optical Drives
IDT High Definition Audio CODEC

Graphics card specs

Name Generic PnP Monitor on ATI Mobility Radeon HD 5850
Current Resolution 1920x1080 pixels
Work Resolution 1920x1080 pixels
State enabled, primary
Monitor Width 1920
Monitor Height 1080
Monitor BPP 32 bits per pixel
Monitor Frequency 60 Hz
Device DISPLAY1\Monitor0
ATI Mobility Radeon HD 5850
GPU Broadway
Device ID 1002-68A1
Subvendor HP (103C)
Current Performance Level Level 1
Voltage 0.900 V
Die Size 40 nm²
Release Date Jan 7, 2010
DirectX Support 11.0
OpenGL Support 5.0
Bios Core Clock 300.00
Bios Mem Clock 400.00
Temperature 72 °C
Core Voltage 0.900 V
BIOS Version BR040240.001
ROPs 16
Shaders 800 unified
Pixel Fillrate 1.6 GPixels/s
Texture Fillrate 0.0 GTexels/s

Any help or advice would be appreciated.


Pte Jack

I have same problems at my job. The problem is the ATI videocards. And the mobility versions the more problems…
Sad, but Blender has very big problems with ATI cards…
At my job it is impossible to use Blender on laptop. The UI is buggy and the freezes you write…

Change the main 3d view window to a user preferences window (from the dropdown selector at the bottom left corner of the window). See if this works any better

Thanks Richard, I tried that. Same result, System tab freezes the application.

Oh oh, this is not a good thing. I run ATI Cards on all my desktops ranging from 4800 to 6700 series cards.

(hmmm, wondering if the Blender developers aware of this?? Must be!!!)

A bug report is the best way to be certain :wink:

I attempted to run Blender on 2 of my other desktop machines, one an Intel i7 Processor with an ATI 4600 Series card and the other with an AMD 955 processor and an ATI 6700 series graphics card (Both Radeons) and I did not encounter this problem with the user menus. All displayed properly and instantaneously.

It would seem that the issue lies with the laptop Mobility ATI card. All other functionality in the program seem to work, so I’ll attempt to learn on the laptop with the standard system settings and port to the desktops as required.

From the blogs and other forums I’ve read, it would seem that integrated graphics cards have been a major bane throughout the development of Blender.

Thanks to all that have responded, and I look forward to new posts on this.

Psy-Fi, where would one post a bug report? I did not see a link in this forum, not did I see one in the forum on


Pte Jack

Hi Pte Jack, it looks like some issue in blender with ATI and OpenCL. The issue has been fixed, see:

Thanks for the links Psy-Fi, they were helpful. I’ve posted a ticket there as I cannot see a second instance of OpenCL on my machine.

I’ve used Windows System Information, Piriform’s Speccy and CCleaner and the ATI Catalyst software to search for a second instance or a second driver. The only other display driver I found was a Windows Live Display driver and after disabling that I retryed Blender. Same result, Black Screen of Death.

HP does not allow access to hardware BIOS settings (I’ve posted a help request in the HP forums for Bios Help), so I cannnot check there for an Intel Chipset that may be loading another driver. As far as I can tell the only driver loaded is the ATI driver.

Just got to love Laptops.

Any suggestions of where else I might search for this phantom driver?

Thanks again,

Pte Jack

For those following this thread I have discovered that the problem might be caused by multiple OpenCL drivers being loaded (as responders have pointed out eariler, thanks guys).

Working with Psy-fi, abc123 and Richard, I posted a question on the Blender Development Site which lead me to a to the discovery that my system currently runs one OpenCL Platform with two devices running drivers. The name of the program used was GPU_Cap Viewer.

I was informed that the multiple OpenCL problem had been repair for the ATI Card in a newer rebuild of Blender however when I tried version r44310 I found that I had the same problem as I did with r44136

Using this GPU_Cap program I stumbled onto another problem which might indicate that there may be a problem with the OpenCL Drivers or my integrated video interface/card itself.

When running the four OpenCL tests/demos in GPU_cap I receive intermittent errors that cause the OpenCL to fail. Intermittent meaning that sometime I can run the demos/test without any problems then re-run the demos and they will either fail or work.

When the demos fail I receive the following error message in GPU_Cap

CL kernel Compile

C:\Users(username)\AppData\local emp\
variable “cs”
was set but never used
float cs = 0.0f

C:\Users(username)\AppData\local emp\
variable “cs”
was set but never used
float cs = 0.0f

calcCompile failedError: Creating kernel surface_deformer_with_check failed!

As OpenCL crashes two programs, it leads me to believe that the problem is in the machine drivers or hardware. So I have posed a question on the AMD OpenCL Developers site as well.

Using GPU_Cap I have found that I I have one OpenCL Platform using two Devices

Here are the specs.

I am currently using ATI Catalyst Drivers:

Drivers Version: 8.820.5.1000 - Catalyst 12.1 (3-31-2011)
ATI Catalyst Version String: 12.1
ATI Catalyst Release Version String:

OpenCL Infor and Drivers

Number of CL Platforms: 1: AMD Accelerated Parallel Processing

Number of CL devices: 2

  1. Juniper
    Type GPU
    Ver. OpenCL 1.1 AMD-APP (851.4)
    Driver: CAL 1.4.1016 (VM)

  2. Intel® Core™ i7 CPU Q 740 @ 1.73GHz
    Type: CPU
    Compute Units: 8
    Clock: 1729MHz
    Ver: OpenCL 1.1 AMD-APP (851.4)
    Driver: 2.0

I am closing this thread as this is now a technical issue; not an artist’s issue.

Thanks to abc123, Richard Marklew and a special thanks to Pys-Fi, who all pointed me in the right direction.

For those who wish to track the progress of this issue the following links are active.

Link to question posted at Blender Development

And the link to question posted at AMD OpenCL Development

With kindest regard

Pte Jack
(Always remember to turn the Blender off when not in use!!!)

under linux you can use utility like strace to debug what’s happening, or you can run blender with LIBGL_DEBUG=verbose ~/bin/blender to know something about the OpenGL environment, try to find something similar to strace but for Windows and use it.

Thanks ble (sorry english only keyboard),

Will strace debug OpenCL (different from OpenGL) in Linux? Unfortunately this does not help me, but will be of definate use to Linux Users. I’ll have a look for a Windose ver or similar product though. Anything to help with the development of this great application (Blender)!

What I have found is a program called Process Monitor v2.96 as a Strace equivalent for Windows. Haven’t had much of a chance to examine if it will actually record OpenCL processes yet, but it does monitor virtually everything. Found it at this link.

(Again thanks Ble)


Pte Jack
On, Off, Pulse - Happy Blending!

Follow up to the issue.

I posted a question to the ATI/AMD OpenCL Forum asking questions about drivers and hardware issues. I did not receive any responses in the forum.


AMD has released a ATI Catalyst driver update on 3 March, 2012. Since installing the new driver my issue is gone.

Newest driver set is 12.2 for mobility graphics.

Newest OpenCL driver included in the upgrade is OpenCL 1.1 AMD-APP (898.1) driver version is CAL 1.4.1703 (VM)

Hope this helps as my issue has been resolved.

Regards and thanks for all the help…

Pte Jack