Blender 2.66 RC

Hi, Blender 2.66 Release Candidate is out, hop:


I noticed something and I want to share: the latest RC Build of Blender 2.66 I did a performance test with GPU render and I noticed a slight braking performance compared to the first release of official test:

2.65.10 r54336 ----- 00:58:30

2.65.10 r54535 (2.66 RC) ----- 01:07:40

same file, same card (Asus GTX 560 Ti)

You should report it to blender bug tracker.

@ Orom,

On OS X I got a 34 second speed improvement!

reported :slight_smile:

I also get quicker render results with the RC vs. the testbuild - about a 5 or 6 second difference, which might be more significant on a slower machine. So it’s all thumbs up for me.

i7-3930K, 32gb RAM (DDR3 @ 667MHz), GTX-670 (2048mb GDDR5), running off a SSD

a 2:30 min rendering went down to 1:50 with Mikes BMW scene.

Excellent! :smiley:

There was a bug in the Testbuild1, it only used the SSE2 CPU Kernel, instead of the SSE3. This should explain the big performance boost for you Claas in RC1.

Hi DingTo

that also could explain why in general I got up and down values. Anyway faster speed is always welcome.

I went back to Mental Ray for a project and I must really say while Cycles is slower the progressive render approach is still faster specifically with textures and fine details compared to Mental Ray and good AA values to make textures even usable.

Great job guys!

Dose anyone else experience the lack of transperancy in the compositor?

Open bugreports down to a record low 44! Looking forward to official release tomorrow :slight_smile:

Greeeeeat effort guys, looking forward to tomorrow! You’re all champs! :slight_smile:

A long shot…

Have you tried setting Properties > Render > Shading > Alpha to Transparent?

Keep in mind, this is just a guess.

I thought that I was having issues with addons again, but in both 2.65a and 2.66 rc I have observed strange behavior. I extrude a ring of verts, switch the manipulator to ‘normal’ and both with wacom pen and mouse, when I try to touch the manipulator gizmo, my view rotates as if I was using mmb on the mouse, or alt-click with the pen. I then try to use the other buttons, and then everything is wonky til I close it again and start over. Seems to me that it is related to using the manipulator, was wondering if anyone else found this behavior when using ‘normal’ with the manipulator. I could prepare a bug report, but would like to avoid that til I can confirm.

What I did to reproduce this:

  • added a circle
  • went into Edit Mode
  • extrude the entire ring of vertices
  • changed Transform Orientation to ‘Normal’
  • clicked in the white circle of the manipulator and dragged it around

Results were as expected. The circle of vertices moved. I didn’t observe the behaviour your described.

However, is the procedure I followed the same as the one you followed? If not, please post a more exacting list of steps.

No, same procedure. I am thinking this is somehow specific to the file, since I went back to do the same from the default cube minus one face, and got the expected result. I will append the object to a new file and see if that fixes the issue. Thanks for responding, Rontarrant

I have tried this but then you don’t get a sky channel in the render. Very often I find it useful to have both, but this apparently no longer works.:frowning:

Hi, Blender 2.66 Release Candidate is out, hop:

No OSX build?
ha ha ha
get out of here, that was enough

michalis, please wait for the official release. would miss your sculptures.
And now that dyntopo is here? And hair, ah, ha, one moment, what am I spreading - it’s not really here currently, am I wrong? At least I could not find the controls for it. I’m sure, even a blind chicken would find it, I must have missed it. My beard is getting grey.

No I won’t wait.
Of course, on, you can find better builds than any official one. And more recent builds obviously.
But, there is a kind of a racism around, that I don’t like.
“here is the new release” blah blah. No OSX build.
It’s symbolic you see.