Blender 2.66a Problems

I recently installed Blender with the 2.66a Windows 32 Installer on this machine:

Dell 3400
Intel Core2
4300 @ 1.80GHz
1.79 GHz, 2.00GB Ram
Radeon X300/x500/x1050 Series
WinXP Pro SP3

I’m relatively new to Blender but experienced with Rhino 3d v4 which runs OK on this machine.
When I run Blender it seems to operate properly but after a few moments of manipulating the viewport and objects in it with the mouse the Blender Window suddenly goes mostly blank. The viewport and most other objects such a menus, toolbars, layers, etc disappear only to reappear when moused over or clicked on and then disappear. Very strange. I uninstalled Blender. I downloaded Windows 32 Zip file and ran Blender from the exe file. Still the same problem. How should I approach solving this problem?
Thanks And Best Regards,

Add more RAM.

Hi, change settings in User Preferencees > System > Window Draw Methode.
Try different settings.
If you cant reach UP from file menu change 3DView to User Preferences.

Cheers, mib.