Blender 2.70 & ctrl-a

Following a tutorial by Andrew Price I’ve come to a stand still, in order to unwrap I get an error message.
Then using Ctrl - a I get no action I’ve reset to factory and still nothing.
Any suggestions would help, I’ve searched the web, oh the tangled web.

What actually is your problem ?
I assume the error message when you tried to unwrap was because you had a non uniform scale. Ctrl+A / scale would correct this. So what now is the problem ? If you don’t see the unwrap in the UV/Image Editor window ensure it is not already showing the Render Result. If it is just delete it with the X button

Make sure you are in object mode when you try to apply scale/rot/loc.

I’m in edit mode since obj.mode won’t allow it and I can see the uv map with the unwrapped item. It isn’t showing in rendered items. I tried resetting to factory mode still won’t allow it. Still the problem persists.

The UV unwrap doesn’t show in Object mode, but that is fine. In Object mode, apply scale and rotation with Ctrl-A and then you can tab back to edit mode to unwrap.