Blender 2.72 - selection issues in Object mode....

Hi. Long time no see, I am swamped from everywhere, so forgive me if this was asked or discussed, just merge me there then :smiley:

Anyways. Since 2.72 selection in Object mode is horrible.
Chances are 50/50 that either nothing is selected, although the object is under the mousecursor, or some other closeby object is selected… in solid and wireframe mode.

Is there something broken with the selection code, or is it in some kind of transistion.

It’s a real PITA to work that way :slight_smile:


A real pita indeed.
As a workaround, under preferences / system, somewhere in the middle of the panel, try “openGL select”
Possibly a bug related to OGL occlusion queries ?

I had a similar problem with bones:

I downloaded buildbot version and the problem has been fixed. You try downloading from buildbot:

Thanks, that helps… I agree, most likely a bug in the occlusion query selection thingy, and as it doesn’t happen with the buildbot version most likely fixed already.

But it gets you wondering, how can they release a version where selection isn’t working properly? Did no one ever test it?
Having that version as official download is like trying to sell a dead horse to already sceptical coboys… and girls :slight_smile:

Looks like a few glitches have crept into 2.72. Just discovered that ‘limit selection to visible’ in mesh edit is not behaving, unless I’m doing something wrong…?

The problems with these things may be GPU and even driver-specific. Devs don’t have access to all GPUs and systems on the planet. If more people would’ve tested the release candidates, the less such problems would’ve gotten into final release.

In this case, the problem occurs only in 2.72 on the same machine with the same GPU and drivers version. Versions prior to 2.72 work well. So, I don’t know if in this case the problem could be related to the drivers.

(my card is an nvidia, but the problem seem fixed in buildbot version anyway)

You misunderstood me, YAFU. Of course it appears only on 2.72, because it’s the version where new selection mode was introduced. I was merely answering arexma’s wonderings on “did no one ever test it?”: it might’ve worked for somebody perfectly fine while would fail on some other machine.

Building at home, testing 3-4 builds a week, I noticed this issue, can’t recall when it started happening.
Between 2.71 and 2.72 for sure. Developers were aware of this, actually a dev advised me to disable OGL occlusion queries or Automatic selection option. (On OSX / ATI GPU)

You are right Stan Pancakes. But in my case the problem was not solved by choosing other selection methods from user preferences in 2.72, so I don’t know.

Yes, bone selection was a separate issue and I believe it’s fixed in the just released 2.72b.

Has got same issues on different machines with different GPU - from none to GT 450 and to 2x GTX770.
A very strange is that issue, that none of selection modes doesnot help.

I using mostly 2.70, so I saw this trouble a couple of weeks ago)

I am using OSX Yosemite Macbook Air. Really weird but this works for me:
Control + 2 finger click (the same way you use 2 fingers for gestures on your keypad).
Control + 1 finger click does not work… only with 2 fingers.
I hope this helps as this was very frustrating for me as well even with the latest 2.73 version of Blender (as of this reply).