Blender 2.75 not showing my GPU as Compute Device Radeon 7970 Ghz Edition

Hello Folks,

I’ve been really looking forward to use Cycles with my GPU, listed in the title. For some reason, the Blender user preferences still won’t list my GPU under System->Compute Devices. What did I miss? Do I need some special drivers to use OpenCL in Cycles?

Currently dissapointed,

me too!!!:frowning:

Of course it would help if we’d knew anything at all about your system.
Right now we don’t even know what OS you’re on…

Cycles GPU rendering is currently in a beta stage, for all graphics cards. Your graphics card is known as an AMD graphics card, so you would need to enable OpenCL to use your GPU. Note that OpenCL rendering is very primitive, with no support for HDR textures, a potentially unresponsive window when rendering, lack of memory sharing (between individual graphics cards), and other issues. You would only be seeing a maximum of a 20% decrease in render times, with an average of about 10%. That is assuming your GPU can even handle your scene, so you might waste more time messing around to get things working that if you just rendered with your CPU.

However, feel free to attempt GPU rendering if you'd like. You will need to enable OpenCL rendering first, so [here]( is one article that may help you.

Cycles GPU rendering is not in a beta stage…it never was. Not all features are supported on GPUs, but that does not make it a Beta.

@nico90: Make sure your GPU drivers are up to date.