Blender 2.76 suddenly very slow

I was working with a simple mesh in 2.76 and suddenly I got an error message about my graphics driver and that the program would have to close. Now blender is very slow and nearly unusable. I have Win 10, a very capable graphics card and have been using this config for several years. Drivers are up to date.

I also get a prompt to ‘reload trusted’. Not sure what this means…

Any ideas???

PS. Just updated to 2.78, same problem…

Replying to my own thread here… FIXED. Right clicked on Blender shortcut and under ‘run with graphics processor’ I re selected ‘run with integrated graphics’ instead of GeForce card. Phew!

Weird… i got the same thing last night… How to set it so that you don’t have to do it every time you start up blender?

Log in to the site and answer five weekly polls
Collect 5,000 points to win 50 dollars
Trusted Sitehttps ://

Same with me that Blender was really slow today. I noticed my Nvidia driver was updated this morning so that is likely causing the issue. Now see if I can sort out the driver to a version that hopefully works…

My integrated graphics card does indeed work ok as work-around but that is not why I have a dedicated graphics card.

Oh me too. Yesterday evening I closed my app for an hour, and when I came back to it (2.78a, btw, on Win 10) it was in total lurch mode. I’ve done everything this morning – run checkdsk, destroyed my user preferences file, and finally downloaded 2.78b… and still I couldn’t even rotate a default cube. I read this thread, opened Blender with integrated graphics, and voila! Performance is restored. Now I shall go pick up NVidia by the lapels and shake them gently.

Ive got the same problem. Earlier today works fine and now blender is really slow. Integrated graphics isn’t any better. What’s latest driver update that causing issues? My last update is 376.54, worked fine til today. Should I even update to latest, 378.49?

I removed the current driver and downloaded the latest drivers (378.49) and that works for me now. Still a complete mistery why the auto update apparently did do something but not take the latest driver … Could be that the issue version for me was 376.54 (did not write down the exact number but it seems to ring a bell in my memory)

I went ahead and updated to 378.49 and everything seems to work again. I don’t know how drivers work, but it’s weird how they work good and then stop. They must have em on a timer,LOL.

This is what happened. Windows 10 seems to have downloaded and installed it automatically. Can I use the “roll back” option to make Blender happy again?

never use the rollback.

That’s what I was afraid of.


My problem is solved. I finally drilled down through all the nvidia websites, found some customer support and sent an email. They recommended driver to download and gave the steps to make it a clean install. This worked, and the lag is gone.

If you have a GEForce GTX 960M, you can download the driver here: