Blender 2.77 STL export problem

Hey everyone,

Just updated to 2.77 and when I tried to export a mesh as an STL, all of the meshes on every layer were included in the STL file. The only way I found to get around this problem was to delete all of the meshes except the one I wanted. Has anyone else experienced this? I think I’ll be going back to 2.76.


Hi threediva,

the new 2.77 has an export option dialog for stl. When you clik export, look left the options that you have and choose selection only.


This worked! Thank you, Kyriakos

If anyone from Blender development is following this thread, I’d just like to point out that it would be helpful if “selection only” is the default without having to have the box ticked. It’s almost a nonexistent possibility that someone would want to export every mesh in a Blend file as one STL file, and therefore it should not be the default. If someone wants to do that (and for the life of me, I can’t imagine why they would), then this should be the clickable option. Thank you!

Hello, Kimberly, thanks you so muck