Blender 2.79/2.80 build without dual render GPU+CPU


I’m on a laptop with Optimus (Discrete GC: Nvidia Geforce GT 640M and Integrated GC: Intel HD). And ever since the 2.79 builds came out with GPU+CPU rendering I have had a problem when running Blender. My problem is that with dual render builds, it seems that something is always soliciting the GPU and CPU even when I’m not doing anything in Blender and I can see the temperatures of my whole system (gpu and cpu) slowly but steadily increasing until my fans kick in and the temp stabilizes at around 57C (on a cool day).

I don’t have this issue/behavior with Blender 2.79b without Dual render, and the temp when doing nothing is around 45C. On a hot day I don’t use Blender because it simply makes my laptop too hot.

I could keep using 2.79b, however I want the bevel node, the displacement node, the vector displacement and the AO node.

Does anyone know if a build exists without dual render (just with GPU as in 2.79b).

If not, does anyone know where in the code that could be disabled?

Thank you for your help.

Disable cpu rendering in CUDA tab.

Thank you for the answer. I have done that but it doesn’t work. I have also tried running Blender with just Nvidia card and just with CPU (Optimus allows right on application and “run with this graphics card”).

I know the GPU is always solicited by something because I can see it on the “Nvidia GPU activity monitor”. On 2.79b/ pre dual render builds, it only shows GPU activity when I’m really doing something with the GPU (basically when I render with it) and then it shows no GPU activity when the render is finished or I leave preview render.

With dual boot builds, as soon as I select “cycles” in the render engine list, or open the preference/system tab. The GPU starts being used and the fans go on, etc. and it doesn’t stop even if i go back to Blender render. I had to select Blender Render in the engine list and save the startup file that way to prevent this behavior.

You can see on the right the activity icon is on even though it says “none”.