Blender 2.79 crash in standalone mode or embed mode with disable shadows


(linuxfree) #1

I cant run my game with no shadows. The start but play crazy animation player and brick with appcrash in blendeplayer.exe or close all screen.

Look picture i try use framerate in 60fps and disable material caching in render properties

and firstly deform animation from player after crash and close game.


Anybody can know what can make this?

I discover today if i made arm(mesh of player) to invisible can play normally with no shadows but lost weapon and obviously animation too.
Ohter thing my playerrig i can’t made apply scale the arm is 1.0 1.0 1.0 the Camera is 1.0 1.0 1.0 but player rig everytime work only in 0.275 0.275 0.275 arm have a armature add modifier with link to player_rig. The arm is child of player_rig
I think if not a bug the problem can be here.but how can i solve that?

I resume a blend to enemies and player have all lights and with shadows enable on render properties animations of player stay fine can walk running all fine.But with no shadows crash animations and game after. The problem is here. I try before erase material from player and nothing.
bugtracker.blend

thanks


(Daedalus_MDW) #2

why disable material caching? for me everything loads faster with it on.


(linuxfree) #3

only to made a test. i use script for disable vsync to main scene at start. test with vsync and no vsync with frame rate and no frame rate and nothing.if no shadows crash game. or its a bug or i have serius problem with my player to work without shadows.very strange that.
obs: i have one animation to simulate day-night is using Energy of sun light.this can cause this error?why ocurr distortion of glock weapon in play before crash?


(linuxfree) #4

anybody can help here please?