Blender 2.8 Cant select armature bones

Hi guys, i’m having another rough time with 2.8.

I have an elephant character that was rigged using rigify in 2.79. now in 2.8 I cannot select any of the bones with the sole exception of Ear.L. I dont know whats special about Ear.L, none of the other bones can be selected outright but all controllers can be.

Bones can be selected using box or circle select, but thats a pain.

Very confused, any help would be much appreciated.

blend file included.

Elephant_RigIssue.blend (956.5 KB)

Hey i donwloaded your model and tested here, and everething is fine. I can move all the bones with no problem. I could suggest to you is to check if when you try to move your bones (without the box or circle selected), the mode is “Pose Mode”, like this:


Hope this can help you.

I am indeed in pose mode, but it doesn’t matter if I switch to edit mode. In fact in edit mode, Ear.L even becomes unselectable!

I’ve tried resetting to factory settings, no dice…

all i can think to do is download the latest beta and see if its a bug that got fixed somewhere along the way. How strange! Thanks anyway

This was a bug that is now fixed.

1 Like

Thanks, the new version seems to have fixed it :slight_smile: