Blender 2.8 - during texture painting only one texture slot visible

Hello everyone,

I have been recently playing with the cool new version of Blender, and I was trying to paint a model with two color textures mixed with the color mix node in the shader editor. During painting I was able to see only one texture from the Texture slots. I could easily switch between the slots and paint them but could not see the resulting color from the color mix node. I wanted to do it like in this youtube video but dont know where the problem lies Maybe its a bug or am I doing something wrong? In object mode everything works fine, I can see the textures mixed and when i change the factor slider the shader color changes.
Thanks in advance

Setting Texture Paint Opacity overlay to 0.0 seems to make it work.


I had the same problem but it turned out to be an easy fix. You need to be in rendered mode to see both images combined. If it still doesn’t work, go into the node editor and make sure you have both textures as inputs to a MixRGB then to your material. That should fix it.