Blender 2.8 Eevee hair discrepancy between viewport and render

I’m doing some Eevee hair tests in 2.8 and I can’t figure out why I’m getting a different looking image between the viewport and render.

In the viewport, the hair looks like this:

In the render, it looks like this:

It looks quite a bit thicker and spiky.

Does anybody know why I’m having this discrepancy?
I’ve set the hair children amount and render sample amount the same between viewport and render.

Attaching file for inspection:
2.8 MonkeyHairTest.blend (1.8 MB)

Maybe you should try a new build of 2.8? Your scene looks pretty much the same on my system. Using version: 2.80 (sub 69), branch: blender2.7, commit date: 2019-05-17 23:36, hash: 03672e77836d, type: Release
build date: 17/05/2019, 18:09

1 Like


No, on the contrary. It seems broken in new builds.

Oh, I guess I don’t update that often, as you can see, it works on the build version I posted.

1 Like

@0o00o0oo, Report just in case. First you look if someone has already reported something similar recently

Wait. I just compiled the very latest version and it works correctly. Until yesterday’s version it was broken.
Probably it is related to this:

So you wait to download new build tonight, and test.

1 Like

Hey, thanks @YAFU! Looking forward to testing and seeing it working on a new build. Good to know this is a buggy behavior that seems to have been resolved just in time.

Thanks for testing and writing out the version it worked with! If the new versions don’t work in time, I do have some older versions installed that I can hopefully fall back on.

This evenings build has indeed resolved the Eevee/ Workbench particle bug. Let’s hope it stays gone!

1 Like

The new build indeed did fix the issue! I guess that’s the adventure of using a beta software, haha.

Still, I realize I have 2 issues:

  1. It’s not 100% perfect. Maybe it’s a hair setting thing, but there’s a strand that’s not in the viewport that’s appearing in the final renders:

    This also appears in the Cycles render. I’ve matched the children Viewport and Render amounts (50 each). What other setting am I missing?

  2. Eevee is a lot noisier than I expected. I wasn’t 100% sure it was noise, so I rendered out a turntable.
    So this made it clear for me that the hair in blue light is suffering from noise. What would be the best way to make the renders noise-free? Is it simply to crank up the samples? This was at 7500.
    Or is there a way to control the noise without just making the render time longer?

On a side note, the hair visualization in Eevee is much better and controllable than I expected. In fact, In my tests, it seems surprisingly close to the Cycles quality (well, actually better because I apparently don’t know how to render hair in Cycles, haha). I can’t wait to see what Principled Hair will bring.

Like the image says, ignore the wonky head mesh color and low-res hair.

Eevee took 3:18.98 @7500 samples.
Cycles took 34:07.65 @3000 samples.

And this is what it looks like in LookDev with HDRi:

I mean, that’s just sweet.

ALSO, if anybody has any tips on making a better hair shader in Eevee, I’m all ears! This is just what I figured to do using the Principled Shader.

1 Like

Are you getting hair transparency on eevee hairs now?

use principled hair shader? add redness (to simulate melanin).

I’m not sure what you mean. You can try downloading the .blend file I provided in the original post to see if that answers your question.

As far as I know, Principled Hair isn’t supported yet in Eevee? It’s completely black when I try to use it. Were you able to use Principled Hair in Eevee?

That’s right, not supported:

LookDev is Eevee, using custom environment image and without using World and scene lights by default.
If you configure for example “forest” exr image as environment texture in World tab, and you remove lamps, it should behave the same in Eevee and LookDev:
2.8 MonkeyHairTest_forest world.blend (2.3 MB)

So if it looks different, for better visualization and less noise you should look for better World and lamps settings. Also for the noise I think it is better not to use such low levels of roughness in material. And you use as many render samples as you can.

Oh, nice, thanks for the modified .blend file! I wasn’t asking about replicating the LookDev look in Eevee in my last post, but I actually was curious about how I would replicate it if I wanted to, so that’s pretty cool.

And thanks for the note about the roughness. Any ideas perhaps on how I might be able to reproduce the low roughness look without using that parameter?

Not really. I hope that in the future we can have a less noisy alternative for the case of glossy hair.

1 Like