Blender 2.8 Show Overlays is off but the edges and vertex are shown?
I am following YanSculpts’ tutorial on Youtube.

I noticed that the edges and vertexes are visible when he changed the setting to ‘Edit Mode’ from ‘Object Mode’ although ‘Show Overlays’ is off. But my blender won’t do that. I have to turn on ‘Show Overlays’ to see the edges and vertexes and edit them.

I have no problem of continuing with the rest of the video but I am curious.
Is it something that got updated over Blender 2.8 Beta test period since he made his tutorial?

It looks like these edges and vertexes pop up when you enter edit mode.

It may be that . . . it may be something that has changed between one and the next version of Blender 2.8. December is a long time ago in Blender 2.8 dev time.

Also - welcome aboard! I hope this doesn’t put you off the experience.

1 Like

Edges and faces are also overlays. If you want to see those things, you’ll have to make sure Overlays are enabled. But, you can disable everything else if you wish to only too those things.

1 Like

Yes, you’re right. I get that Overlays are needed to be turned on to see edges and vertexes.
I was just curious because he had them on without Overlays being on in the video.
Thank you!

I see I see.
Thank you!
It didn’t put me off the experience. I think Blender is the best 3D software out there. Can’t wait for the official 2.8 release.