Blender 2.82 keeps closing itself (crashing?) when I want to bake a smoke simulation

I am at a loss as to what to do to prevent Blender from crashing. What I mean by crashing is that it closes itself out, not really pausing or anything, just immediately exiting itself. The reason why it is crashing is because I want to bake some smoke into an animation. It happens whenever I hit “Bake Data” in the Physics Properties, and whenever I want to switch the Cache Type to “Replay”, or “Modular”. Even if I tried reducing the Resolution Divisions from 64 to 32, or switching between GPU and CPU in Cycles, or unchecking the “Use High-resolution Smoke” checkbox, it still crashes. What I have for my GPU is a Radeon Pro Vega 64 16 GB, and for my CPU I have a 3 GHz 10-Core Intel Xeon W. Is there something wrong with my GPU and/or CPU? I installed Windows 10 through Bootcamp on my iMac Pro, thinking that it would let me actually use GPU/CPU in Blender, yet it still crashes when I try to hit “Bake”. Am I missing something? If you have any suggestions, please let me know.

2 Likes

The same thing is happening to me! I downloaded the newest version of Blender 2.92, but it is still crashing.
It closes itself when I am trying to bake a fluid fire.
when I switched over from gpu to cpu I could bake it, but only in 32 divisions, and without too much smoke resolution added. It’s probably some configuration with the gpu?
Anybody can help us?

Try baking to file rather than using ram see if that works

1 Like

I tried that! Didn’t work… but thanks for the idea!

I think is something wrong with the noise (Smoke), when I turn it off it bakes normally … Maybe my gpu can’t process this noise texture…I don’t know!!
I’m a complete noobie T.T

Assuming you’re in Windows, open your task manager and take a look at system resources. With the task manager open, try caching your simulation. If the memory goes close to 100% before Blender closing, then the likely issue is you need more RAM in your computer, or you need to turn down your simulation settings.

1 Like

I was having the same problem yesterday, and watching memory usage didn’t indicate it was a RAM problem…

I realize I am about one year late, but what worked for me is changing the simulation’s Format Volume option from “OpenVDB” to “Uni Cache”, located under the “Cache” section of the Smoke Domain.

I hope this helps fellow artists in the future. I’m using 2.92.0

1 Like