Blender 2.92 clipping occurs inspire of clip start setting......... Anyone?

I just fired up Blender v 2.92, added a cube, set clip start to a very low number and still the cube gets clipped!!! H.E.L.P.! Anyone?..

hello how small is your cube in the scene? also i recommend you this setting, yours its in “cm”, make it “m” instead
Screenshot 2021-03-05 173155

I made a new cube ( 2M by 2M ) and set Units to “Meters”. … to no avail…

View → Regions → Clipping Region.

From the screenshots, it looks like you might have accidentally hit the hotkey for that operator and drawn a clipping region. If you simply run that operator again it’d be cleared.

Welcome to BlenderArtists!