Blender 2.93 viewport performance far worse than 2.90

Hi there!

I’ve noticed that Blender viewport performance is much worse in 2.93 (and 2.92), than it was in 2.90. Usually noticeable slowdowns appear almost immediately when I work with booleans or many mesh linked duplicates, for example. And it doesn’t take much - like having a scene with one mesh and 6 - 8 boolean cutters on that mesh. Moving objects around in such a scene (in object and edit mode) is happening at 2 FPS. This has a major impact on the speed of my production.

If I open the same scene in 2.90, the problems disappear and Blender is lighting fast in all modes.

I’m testing this on the same hardware, same system (Linux), with the same (very few) additional addons installed. Under the exact same circumstances, 2.90 is lightning fast, compared to 2.93.

Has anyone experienced anything similar? Does anyone know what fundamentally changed between these versions, that could have such an impact on performance? Can I disable anything in 2.93 to boost performance? (I only need modelling tools)


I also notice delays,2.93.5, but in posemode!
but they are gone when I load the factory settings,

maybe try it out how it runs with it,
i haven’t checked yet which addon is causing the delay, too many!

Loading factory settings ‘fixes’ the problem, but only if I load without “Load UI” enabled. If I load a .blend file with “Load UI”, the slowdowns still persist. That’s in 2.92 and 2.93 - Blender 2.90 still behaves normally, regardless how I load a scene.

Really weird. Is there something in the specific GUI layout that is causing this? Though I haven’t really changed anything drastically from 2.90 to 2.93.

Note that my Blender setup is also as vanilla as it gets - I only have a handful of official addons installed and I’ve tried disabling everything too.

Holy cow, I found out the issue… and it’s weird. :woozy_face:

I noticed just now that the slowdowns happen only when I’m working in the “Layout” tab (which is most of the time), but not when I’m in “UV”, “Shading”, etc…

In that tab I have the main 3D view, the Properties window and three Outliners - two of those are there just to ‘fill space’, since I have a widescreen monitor. And those Outliner windows are causing the slowdowns!

If I close them or just change them to something else like another 3D view, the slowdowns disappear! Even more: the more outliner windows that I open, the slower Blender gets, lol.

This behaviour is NOT happening in 2.90. Only in 2.92 and 2.93

Try it out - close or change Outliners to something else, and see if it speeds up the viewport

1 Like

Can you try it in the 2.93.6 candidate build:

Blender Builds -

And if it still behaves like that maybe enter a bug for it so someone can check into the cause?

Help->Report a Bug

I tested 2.93.6 and I’m unable to reproduce the problem from a fresh scene. But the projects that caused problems, still have this problem in the latest version. I’ve noticed something more specific: it’s only the “Blender File” display mode of the Outliner, that causes the slowdowns. This one:


It’s only happening when the Outliner is in this mode and with some specific files of mine. There has to be some other variable, related to specific content or setup of those .blend files. I’ll investigate further and report if I find something that can be easily reproduced.

But at least I’m glad to know this is nothing related to graphic drivers or similar issues.

Sounds like another example of KISS - keep it simple squire.

Ok, was able to reproduce this in 2.93.6, I just needed to crank up the amount of objects and the number of Outliner windows. This issue seems to scale with the complexity of the .blend file (amount of items - represented in the “Blender File” Outliner data).

Started with many mesh dupli cubes and 6 outliner windows opened in “Blender File” mode. I’m able to notice FPS drops when I move the cubes, for example in proportional editing mode.

When I change all 6 outliners to 3D view, the viewport performance improves noticeably. This is even more noticeable if the scene is more complex, than just a pile of cubes.

So, if anyone want’s to test this, here’s the file (.zip because for some reason it’s 27 MB, even though there are just meshdupli cubes). Don’t forget to tick “Load UI” in the load window settings. (1.5 MB)

I’ll wait, if anyone else is able to see this problem, before I do any bug reports.

Ok, I filed a bug report and it was confirmed by the devs. I consider this solved.

Thanks everyone for helping me diagnose the problem!