Blender 3.1 Eevee, may not be rendering sunlight volumetrics correct?

If anyone can test and confirm? this is 3.1 alpha though, so maybe a later release it is fixed?
Just tested blender 3.1 volumetrics in eevee, seems something isn´t right with the sunlight to react properly with background volume scatter, tried a box also …but it won´t cast shadows properly.

Settings are the same, but either eevee volumetrics and rendering have changed in 3.1, or a bug…I suspect a bug since I just can´t get the shadow casting going properly.

In 2.9 it works as it should and I saved the scene out and tried to open in 3.1, but still not proper volumetric lighting for the sunlight.

See images…Allmost realtime in eevee, a few secs for volumetric shadow sampling refinement.

2,9 first image, blender 3.1 second image…where it fails, scaling is however reduced from real world scale, since I wanted to test on a pre-made lower scale already setup scene that worked, but shouldn´t be hard to rescale up and change volumetric distancing…at least not in 2.9.

2.9 eevee volumetrics (global scattering)…

3.1 eevee volumetrics (global scattering)

have you changed the start and end distances in the volumetrics panel?

Yep…doesn´t matter, and it´s the same scene you know…so if there´s any change in volumetric distance, that would have changed from these versions, but most likely not since I have tried the changes, nothing happens in casting shadows properly, there´s also a weird light originating effect that doesn´t seem to be right.

I have tried it many many times now…It just don´t work, if anyone else got it working, by all means that should be posted with settings in here :slight_smile:

The volumetrics is the global settings, volume, volume scattering node, no absorbtion applied.
Maybe I should post scene samples, simple box or something from 2.9 working and one for 3.1 not working?

This is Eeeve 3.1 alpha version…
version: 3.1.0 Alpha, branch: master, commit date: 2021-10-29 14:55, hash: dcdbaf89bd11, type: release
build date: 2021-10-29, 23:49:23

I’ve used it in this scene and it seems to work properly, also used a box to scatter the volume. This is Blender 3.1 Alpha same as the one you mentioned.

But using a box domain isn´t the same as the global scattering in eevee, that is where the problem is.
Or did you mean you have tried it both and got it working?
I don´t think it is working, it would have worked with all the 2.9 setups I do, which clearly gives proper volumetrics, while those scenefiles imported in to 3.1 doesn´t work, no matter how I adjust it.

No I didn’t try it in that shot, but tried it now and also working. By global scatter you mean plugging a principled volume to volume in world output node, right? That’s what I tried now but lowered the density to 0.05, also in volumetrics tab I’ve checked both volumetrics lighting and shadows.
I hope this helps in any way.

Yes it is in the world properties and in the volume tab, not surface tab.
but in this case I didn´t use principled volume, just the standard volume scatter shader.

Are you really sure it is working as it should, I mean it yields some kidn of effecgt, but its not correct.
And…You did use a sunlight right, not point lights or area lights?

I know very well how to set the lighting for volumetrics, lowering density and such and enable all shadows…so it unfortunately doesn´t help, and besides, it worked in 2.9 but the scenes and other scenes doesn´t work.

So there´s just not any settings that has changed in the scene, but as you can see from my sample with sunlight )important…it just not working.

Please show me a proper sunllight casting rays as you can see in my first image.

You know…somethings inversed screwed up in 3.1 alpha, when I uncheck volumetric shadows…the lightrays appear…how strange.

In 2.9 the volumetric shadows are checked.

Too note, changing density in scatter volume(with volumetric shadows) with makes it sort of kick in a bit, but it´s not good enough, and completely out of tune from 2.9.

So …perhaps not a bug then, just the scatter volume density that is different, with the density set from 2.9, turning shadows on…it overrides all the light, unless lowering density to ridiculous low values.

I will post some more samples with the different settings tomorrow.
Perhaps record it and put it on youtub with narration …so you can see how 2.9 works and 3.1

Try make an evee scene with sunlight rays in 2.9, save it and open it in 3.1 …and I´ll bet it would be different.

volumetric scattering increase of density, shouldn´t yield a result of darkening cutting of the volumetric rays, on the other hand increase it all, that is what it does without volumetric shadows turned off in 3.1, and with shadows turned on in 2.9.
So I´ll bet there´s something still not right in 3.1

if raising density for volume scatter in 3.1 with volumetric shadows on, just in range between 0,01-0,02 the rays density will be stronger, but above that 0,05-0,08
…it starts to shut down the rays.

Anisotrophy as default set at 0,982